Copyright and Trademark Notice

Copyright © 2001 by Parker Automation - CTC. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, in any form or by any means, mechanical, photocopying, recording or otherwise, without the prior written consent of Parker Automation - CTC.

While every precaution has been taken in preparing this manual, Parker Automation - CTC and the author assume no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of the information contained herein. All product and company names are trademarks of their respective companies and licenses.

Product Warranty Information

Parker Automation - CTC provides top quality products through rigid testing and the highest quality control standards. However, should a problem occur with your hardware or with the software protection key, our standard product warranty covers these items for 15 months from the date of shipment. Exceptions appear below:

- Backlight bulbs have a 90-day warranty.
- Third-party products, such as bus cards, carry the manufacturer’s specified warranty.
- For all displays, image retention (burn-in) is not covered by warranty.
- Software revisions that occur within 60 days after purchase are available, under warranty, upon request. Please review the MachineShop License Agreement for additional software warranty information.

If you have any questions about your application or need technical assistance, please call Technical Support at 513-248-1714, 8:00 a.m. to 5:00 p.m., Eastern Time. You may call this same number after hours for emergency assistance. See Customer Support Services on page 5 for more information about our support products and services.
# Table of Contents

**Chapter 1** Overview and Support Services .................................................. 1
- What’s in this User Guide? .............................................................................. 2
- Documentation Standards .............................................................................. 3
  - ISO Symbols .................................................................................. 3
- Customer Support Services .......................................................................... 4
  - Technical Support ................................................................................. 4
  - Training and New Business Development .................................................. 5
    - Training ..................................................................................... 5
    - Application Engineering Services ......................................................... 5
    - Product Support Program .................................................................. 6
- Documentation ............................................................................................... 6

**Chapter 2** Introducing MachineShop ..................................................... 7
- MachineShop Basics ................................................................................... 8
- Development System Requirements ............................................................ 9
  - Hardware Requirements ........................................................................ 9
  - Software Requirements .......................................................................... 9
  - Installing the Software ......................................................................... 9
- Runtime System Requirements .................................................................... 10
  - Hardware Requirements ....................................................................... 10
  - Installing the Hardware ....................................................................... 10
  - Software Requirements ...................................................................... 11
  - Installing the Software ...................................................................... 11
- Working with Security Keys ......................................................................... 11
  - Understanding the Security Keys ............................................................ 11
  - Using the Security Key Utility ................................................................. 12
  - Enabling Software Options ................................................................... 13
  - Transferring Enabled Options between Keys .......................................... 14
- Getting Started with MachineShop ............................................................ 15
# Table of Contents

Reading IPM Projects in MachineShop .......................................................... 15
Online Help ........................................................................................................ 16
Starting MachineShop ......................................................................................... 16

**MachineShop User Interface** ........................................................................ 17

- **Menus** ........................................................................................................ 18
  - File Menu ....................................................................................................... 18
  - Edit Menu ..................................................................................................... 18
  - View Menu .................................................................................................... 18
  - Tools Menu ................................................................................................... 18
  - Transfer Menu ............................................................................................... 19
  - Window Menu ............................................................................................... 19
  - Help Menu .................................................................................................... 19
- **Toolbars** .................................................................................................... 19
  - Project Management Rebar .......................................................................... 19
  - Suite Navigation Rebar ................................................................................ 20
  - Transfer Rebar ............................................................................................. 20

**Chapter 3  Managing Projects** ................................................................. 21

- **Overview of MachineShop Projects** ................................................... 22
- **Project Directory Structure** .................................................................... 22
- **Startup Files** ............................................................................................. 23
- **Setting the Project Path** ........................................................................... 23
- **Create a New Project** ............................................................................... 24
- **Open an Existing Project** ......................................................................... 29
- **Save a Project** .......................................................................................... 30
- **Delete a Project** ....................................................................................... 30
- **View Project Information** ......................................................................... 31
- **Edit a Project** ............................................................................................ 33
  - **Project Description Option** .................................................................... 33
Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>MachineLogic Option</td>
<td>33</td>
</tr>
<tr>
<td>MachineLogic Memory and Ports</td>
<td>33</td>
</tr>
<tr>
<td>MachineLogic I/O Interface</td>
<td>36</td>
</tr>
<tr>
<td>MachineLogic Runtime Target</td>
<td>36</td>
</tr>
<tr>
<td><strong>Chapter 4 Adding Connections</strong></td>
<td>39</td>
</tr>
<tr>
<td>MachineShop Direct Serial Communication</td>
<td>40</td>
</tr>
<tr>
<td>MachineShop Net Connections</td>
<td>41</td>
</tr>
<tr>
<td>LAN Connection</td>
<td>42</td>
</tr>
<tr>
<td>Ethernet Point to Point Connection</td>
<td>45</td>
</tr>
<tr>
<td>Configure TCP/IP Properties in Windows 95/98</td>
<td>45</td>
</tr>
<tr>
<td>Configure TCP/IP Properties in Windows NT</td>
<td>48</td>
</tr>
<tr>
<td>Configure TCP/IP Properties in Windows 2000</td>
<td>51</td>
</tr>
<tr>
<td>Add Connection in MachineShop</td>
<td>52</td>
</tr>
<tr>
<td>MachineShop Net PPP Connection</td>
<td>55</td>
</tr>
<tr>
<td>Modem Connection</td>
<td>58</td>
</tr>
<tr>
<td>IPM Compatible Connection</td>
<td>61</td>
</tr>
<tr>
<td>Disk Transfer Connection</td>
<td>63</td>
</tr>
<tr>
<td><strong>Chapter 5 Backing Up Projects</strong></td>
<td>65</td>
</tr>
<tr>
<td>Creating a Backup</td>
<td>66</td>
</tr>
<tr>
<td>Local Project Backup</td>
<td>66</td>
</tr>
<tr>
<td>Remote Project Backup</td>
<td>68</td>
</tr>
<tr>
<td>Restoring a Backup</td>
<td>69</td>
</tr>
<tr>
<td>Restore Backup to the Local System</td>
<td>69</td>
</tr>
<tr>
<td>Restore Project to a Remote System</td>
<td>71</td>
</tr>
<tr>
<td><strong>Chapter 6 Transferring Projects</strong></td>
<td>75</td>
</tr>
<tr>
<td>Downloading a Project</td>
<td>76</td>
</tr>
<tr>
<td>Transfer Wizard</td>
<td>76</td>
</tr>
</tbody>
</table>
# Table of Contents

- Download Command ................................................................. 78
- Uploading a Project ................................................................. 80
- Transfer Wizard ........................................................................ 80
- Upload Command ....................................................................... 82

## Chapter 7  Customizing MachineShop ................................. 85

- Set the Visibility ......................................................................... 86
- Move the MachineShop Toolbars ............................................... 87
  - Move the MachineShop Rebars .................................................. 87
- Add, Edit, and Remove Suite Components .................................. 88
  - Add a Program .......................................................................... 88
  - Edit a Program ......................................................................... 89
  - Remove a Program ................................................................... 90

## Appendix A  MachineShop Dial-Up Networking Connections .. 91

- 95/98 Dial-Up Networking .......................................................... 91
  - Create a Dial-Up Connection in Windows 95/98 ...................... 91
  - Configure the Connection in Windows 95/98 ......................... 93
- Windows NT Dial-Up Networking ................................................. 97
  - Create a Dial-Up Connection in Windows NT ......................... 97
  - Configure the Connection in Windows NT .............................. 99
- Windows 2000 Dial-Up Networking .............................................. 102
  - Create a Dial-Up Connection in Windows 2000 ..................... 102
  - Configure the Connection in Windows 2000 ......................... 104

## Appendix B  Cable Pinouts ......................................................... 109

- 10 Base-T, 100 Base-T Ethernet LAN Cable Pinout .................... 109
- 10 Base-T, 100 Base-T Ethernet Peer to Peer Crossover Cable Pinout . 110
- MachineShop Serial PPP Cable with Hardware Handshaking Pinout . 111
- MachineShop Serial PPP Null Modem Cable with Loopback Pinout . 112
Table of Contents

Index .................................................................................................................. 113
Chapter 1

Overview and Support Services

This chapter explains what is in this User Guide. It also describes the documentation standards used in the Guide and important customer support services.

Chapter Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What’s in this User Guide?</td>
<td>2</td>
</tr>
<tr>
<td>Documentation Standards</td>
<td>3</td>
</tr>
<tr>
<td>Customer Support Services</td>
<td>4</td>
</tr>
</tbody>
</table>
This Guide describes the MachineShop user interface and provides instructions on how to create and manage projects which use Interact applications and/or MachineLogic projects.

In the Guide, you will find the following chapters:

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Introducing MachineShop</td>
<td>Hardware and software requirements, navigation, help, and interface.</td>
</tr>
<tr>
<td>3</td>
<td>Managing Projects</td>
<td>Create, open, view and manage projects.</td>
</tr>
<tr>
<td>4</td>
<td>Adding Connections</td>
<td>File transfer setup and MachineShop Net connections</td>
</tr>
<tr>
<td>5</td>
<td>Backing Up Projects</td>
<td>Backup and restore local and remote projects</td>
</tr>
<tr>
<td>6</td>
<td>Transferring Projects</td>
<td>Transfer files to and from the runtime system</td>
</tr>
<tr>
<td>7</td>
<td>Customizing MachineShop</td>
<td>Options and Toolbar</td>
</tr>
<tr>
<td>Appendix A</td>
<td>MachineShop Dial-Up Networking Connections</td>
<td>Create and configure connections in Windows 95/98/NT</td>
</tr>
<tr>
<td>Appendix B</td>
<td>Cable Pinouts</td>
<td>Pinouts for LAN, crossover and serial cables</td>
</tr>
</tbody>
</table>
## Documentation Standards

This Guide uses the following documentation standards:

<table>
<thead>
<tr>
<th>Style</th>
<th>Type of Text</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Important terms</td>
</tr>
<tr>
<td><strong>Courrier font</strong></td>
<td>Text to be entered from the keyboard.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Alternative approaches or issues.</td>
</tr>
<tr>
<td><strong>Important</strong></td>
<td>Information to save time and minimize problems.</td>
</tr>
<tr>
<td><strong>Warning</strong></td>
<td>Information that will prevent equipment damage or personal injury.</td>
</tr>
</tbody>
</table>

## ISO Symbols

This documentation uses the following caution symbols.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Symbol" /></td>
<td>International Standards Organization (ISO) symbol for Caution (ISO 3864 No. B.3.1). Denotes activity that could affect operation of the computer if instructions are not followed.</td>
</tr>
<tr>
<td><img src="image2" alt="Symbol" /></td>
<td>PowerStation PS Series User Guide ISO symbol for Caution—risk of electrical shock (ISO 3864 No B.3.6). Denotes activity that could cause personal injury from electrical shock or damage to equipment if instructions are not followed.</td>
</tr>
</tbody>
</table>
Customer Support Services

We welcome your thoughts and suggestions on our products and services. You can contact us by telephone, email, or fax. You can also visit Parker Automation - CTC on the World Wide Web to learn the latest about our hardware, software, and customer support services.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Telephone</strong></td>
<td>513-831-2340</td>
</tr>
<tr>
<td><strong>Technical Support</strong></td>
<td>513-248-1714</td>
</tr>
<tr>
<td><strong>Fax</strong></td>
<td>513-831-5042</td>
</tr>
<tr>
<td><strong>E-mail</strong></td>
<td><a href="mailto:training@ctcusa.com">training@ctcusa.com</a>, <a href="mailto:appeng@ctcusa.com">appeng@ctcusa.com</a>, <a href="mailto:sales@ctcusa.com">sales@ctcusa.com</a>, <a href="mailto:support@ctcusa.com">support@ctcusa.com</a>, <a href="mailto:DocComments@ctcusa.com">DocComments@ctcusa.com</a></td>
</tr>
<tr>
<td><strong>World Wide Web</strong></td>
<td><a href="http://www.ctcusa.com">www.ctcusa.com</a></td>
</tr>
</tbody>
</table>

We recognize that every customer and every application have different support needs, so we offer four types of customer support services:

- Technical Support
- Training and New Business Development
- Product Support Program
- Documentation

Technical Support

The Technical Support department welcomes your questions as you develop or run your applications. We offer complimentary support for any customer, whether you are an end-user, original equipment manufacturer (OEM), system integrator, or distributor.

If you have a question about MachineShop, Interact, or MachineLogic, be sure to complete the following steps:

1. Check the Readme files installed with the software. These files provide general information about the release.
2. Consult the appropriate documentation and other printed materials included with MachineShop, Interact, and MachineLogic.
3. Check the online help. MachineShop, Interact, and MachineLogic each have extensive online help facilities that cover all aspects of the product.
If you cannot find a solution using one of the preceding sources:

1. Call your CTC products distributor for support.
2. View the Technical Support web page at www.ctcusa.com. You’ll find answers to Frequently Asked Questions, application notes, product user guides, and software downloads that may be helpful.
3. Call Technical Support at 513-248-1714, 8:00 a.m. to 5:00 p.m., Eastern Time.

You can call this same number after hours for emergency assistance.

**Training and New Business Development**

Parker Automation - CTC supports all products through training programs, consulting services, and a Product Support Program.

**Training**

We offer training on all of our products, either at Parker Automation - CTC, in our state-of-the-art training center, or at your site. You can learn how to:

- Write custom interfaces
- Develop specialized applications
- Implement your complete operator interface application

To contact the Training Coordinator:

<table>
<thead>
<tr>
<th>Telephone</th>
<th>1-800-233-3329</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail</td>
<td><a href="mailto:training@ctcusa.com">training@ctcusa.com</a></td>
</tr>
</tbody>
</table>

**Application Engineering Services**

We offer consulting services through our Application Engineering Services group. Our Application Engineering group can build your application from the ground up:

- Write custom communications drivers
- Design special modules to perform functions unique to your application
Our specialists are flexible, so they can create a project development schedule that meets your needs. You can contact Application Engineering Services in one of the following ways:

<table>
<thead>
<tr>
<th>Telephone</th>
<th>1-800-233-3329</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail</td>
<td><a href="mailto:appeng@ctcusa.com">appeng@ctcusa.com</a></td>
</tr>
</tbody>
</table>

**Product Support Program**

The Product Support Program (PSP) is designed to keep you up-to-date with the current versions of Parker Automation - CTC software. It’s an easy, cost-effective way to receive the most recent CTC software and associated utilities. The PSP consists of a renewable, one-year membership that provides you with the following:

- Free upgrades and utilities
- E-mail notification of software updates
- Valuable tools for MachineShop, Interact, and MachineLogic

Single-user, multi-user, and corporate licenses are available. To learn more about PSP, contact us:

<table>
<thead>
<tr>
<th>Telephone</th>
<th>1-800-233-3329</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail</td>
<td><a href="mailto:sales@ctcusa.com">sales@ctcusa.com</a></td>
</tr>
</tbody>
</table>

**Documentation**

You can download CTC product documentation from our Web site at www.ctcusa.com. Click **Support** and then **Product Manuals**.

We also welcome your comments on this User Guide or any of our other documentation. Please e-mail your comments to mail to: DocComments@ctcusa.com
Chapter 2

Introducing MachineShop

MachineShop is a suite of software products designed for machine control. The Suite includes three machine control programs: Interact, MachineLogic, and the MachineShop Toolbar. The MachineShop Toolbar provides a simple user interface for managing a machine profile or project. The machine control programs that are managed by the MachineShop Toolbar are modular and may be used independently of one another.

This chapter describes the features of MachineShop and introduces you to the MachineShop Toolbar. It also describes the system requirements for the MachineShop development and runtime systems.

Chapter Contents

MachineShop Basics 8
Development System Requirements 9
Runtime System Requirements 10
Working with Security Keys 11
Getting Started with MachineShop 15
MachineShop User Interface 17
MachineShop has a simple, easy-to-use interface for configuring and managing machine profiles or projects. Through the use of wizards for multi-step procedures and explorer-type windows for file management, MachineShop has simplified and automated the most common tasks associated with machine projects.

MachineShop provides the necessary functionality to develop projects, including creating new projects, opening or backing up existing projects, launching various Suite programs, and transferring projects and files to and from runtime workstations such as PowerStations.

The purpose of MachineShop is to perform the following operations:

- Provide a central location for managing the development and runtime files for Interact and MachineLogic, whether used together or separately
- Provide a simple user interface for transferring projects and their components to target runtime workstations such as PowerStations
- Provide a simple user interface for backing up and restoring projects to/from runtime workstations or a variety of storage devices (diskette, Compact Flash, hard drive, network, etc.)
- Provide a variety of communication options for transferring projects and performing backups, including serial, LAN, and disk connections

The next section of this chapter will list the hardware and software requirements to run MachineShop. The remaining sections of the chapter will discuss working with security keys and getting started with MachineShop, including how to get help.
Development System Requirements

The development system is the computer you will use to create and manage your MachineShop projects. Do not use the development system to run the projects that you create. Instead, transfer the projects to a workstation designated to run the projects.

Note Throughout this manual, we refer to a workstation that runs MachineShop projects as a *runtime system*. A runtime system is a PowerStation or Industrial PC designated to run the projects that you create. This manual assumes you are using a CTC PowerStation as your runtime system.

Hardware Requirements

Your development system must meet or exceed the following system requirements to run MachineShop as intended:

- Processor: Pentium 133MHz
- Memory: 24MB RAM (Windows 95/98 systems)
- Memory: 32MB RAM (Windows NT systems)
- Fixed Storage: 50MB of free hard disk space
- Removable Storage: CD-ROM drive
- Input Devices: keyboard and Microsoft compatible mouse
- Video: 800 x 600 resolution, 256 colors
- 10 MB Ethernet network interface or serial port

Software Requirements

Your MachineShop development PC requires the following software in order to develop MachineShop projects:

- Operating System: Windows 95 4.00.950B (OSR2), Windows 98, Windows 2000, or Windows NT 4.0 SP3

  Note You must install DCOM 95 if you are using Windows 95/98. The MachineShop install CD provides a self-extracting executable install in the DCOM 95 directory. This directory is automatically installed when you install MachineShop.

- Interact: Version 6.0 if you are using Interact with MachineLogic, Version 5.0 or later for all other instances
- MachineLogic: Version 2.0 or later

Installing the Software

Runtime System Requirements

The runtime system is the PowerStation or industrial PC designated to run your MachineShop projects. You will develop your projects on a development system and then download them to the runtime system. Use the runtime system to run projects only.

**Note**  The development system is the PowerStation or Industrial PC that you use to create your projects.

The runtime system requires MachineShop Shell to operate. MachineShop Shell is an easy-to-use interface that communicates with the MachineShop development machine. For more information on the MachineShop Shell, see the *MachineShop Shell Runtime User Guide*.

### Hardware Requirements

Your runtime system must meet or exceed the following MachineShop system requirements in order for MachineShop projects to perform as intended:

- **Processor**: 80386-SX 25MHz or higher
- **Memory**: 4MB
- **Fixed Storage**: 8MB
- **Video**: 320 x 240 or 640 x 480 resolution, 16 colors
- **Input Device**: Microsoft compatible mouse or equivalent
- **Third Party I/O Card**
- **MachineLogic Control Adapter or MachineLogic Slot Card**, if using MachineLogic
- **10MB Ethernet network interface card or serial port**

**Important**  A MachineLogic adapter card must be installed before you can use projects that include MachineLogic components.

### Installing the Hardware

To run MachineLogic projects on your runtime system, you must install a MachineLogic adapter card and the appropriate I/O card on the runtime system. Refer to the *MachineLogic Runtime Hardware Installation* document and the document that came with your I/O card for step-by-step instructions on how to install both the control adapter card and I/O card.
Software Requirements

Your runtime PC requires the following software in order to run MachineShop projects:

- Operating Systems: MS-DOS 6.22 or later
- Interact Runtime: Version 6.0 or later if you are using Interact with MachineLogic, Version 5.0 or later for all other instances
- MachineLogic Runtime: Version 1.11 or later
- MachineShop Shell: Version 1.0 or later

Installing the Software

Refer to the MachineShop Installation Booklet for step-by-step instructions on how to install and setup the MachineShop software components.

Working with Security Keys

The MachineLogic and Interact software that you installed from the MachineShop CD runs with a security key. This section describes how to view and enable key options.

Note  The MachineShop Toolbar is not key protected and may be used on any appropriate system to transfer projects, create runtime system backups, or restore runtime backups.

Understanding the Security Keys

The MachineShop CD includes a security key. The label on the security key indicates the key type, key number, and the serial number as shown below:
Every security key has a unique 15-digit serial number. This serial number provides assurance that unauthorized users cannot use your copy of the Interact and MachineLogic software without violating the License Agreement. Your key has a unique serial number. Through this serial number, we enable only the software options you purchased.

To connect the security key, complete the following steps:

1. Plug the security key directly into the parallel (printer) port of your computer.

   **Note** The key’s presence will not affect your printer’s performance.

2. Plug the printer cable into the other end of the key.

The Security Key Utility allows you to program your Security Key. You can enable additional software options or transfer enabled software options between keys.

A sample of the Security Key Utility screen is shown below.

For most users, the options that you purchased are enabled at the factory before the product is shipped to you. Checkmarks should display for each option you ordered. If you do not have check marks next to the options you purchased, then you must enter the 8-digit enable codes printed on the Module Enable Code Certificate.
Enabling Software Options

When you order additional software components, you will receive a Module Enable Code Certificate listing enable codes for each software option purchased. These enable codes are used to activate the respective software options on the security key. The codes are generated for the key number and serial number printed on your key and are valid ONLY for that key.

To enable software options, follow these steps:

1. Install the software on your system following the procedure described in the MachineShop Installation Booklet.
2. Make sure your key is attached to the parallel port of your computer.
3. Click Start on the Taskbar.
   The Start menu opens.
4. Select MachineShop from the Programs folder.
   The MachineShop folder opens.
5. Click the Security Key Utility icon.
   The Key Setup Main Menu is displayed.
6. Select the Enable Option command.
7. Enter an enable code to activate a software option.
   Note After you enter the enable code, a check mark will appear to the right of the enabled software option. If the enable code that you entered will activate development, two check marks will appear, one in the Configuration column and one in the Runtime column.
8. Repeat steps 4 and 5 for each enable code.
9. Return to the Security Key Main Menu.
10. Select the Exit menu option to exit the Security Key Utility and return to the Windows desktop.

Transferring Enabled Options between Keys

Enabled software options may be transferred from one key to another. You must have two keys in order to transfer enabled options, and both keys must be attached to the computer at the same time. You can plug each key into a separate parallel port, or you can cascade the two keys together and plug them into a single parallel port.

The Security Key Utility identifies one key as the source and the other as the destination. Enabled software options can only be transferred from the source key to the destination key. Enabled options that were originally activated with an enable code and subsequently transferred can be re-enabled only by transferring them back from another key.

To transfer options between keys, follow these steps:

1. Attach two keys to your computer (each in a parallel port, or cascaded).
2. Click Start on the Taskbar.
   The Start menu opens.
3. Select MachineShop from the Programs folder.
   The MachineShop folder opens.
4. Click the Security Key Utility icon.
   The Key Setup Main Menu is displayed.
5. Select the Transfer Option command from the Main Menu.
   The Key Setup Utility automatically detects the two keys and displays the options enabled in each one.
6. Select the Select Keys command from the Transfer Options menu to identify which key is the source and which is the destination.
7. Click on the Select Keys command to alternate source and destination, if necessary.
8. Choose the Select Option command from the Transfer Options menu.
Chapter 2: Introducing MachineShop

Getting Started with MachineShop

9. Select the option you want to transfer from the list of enabled options in the source key.

   If necessary, specify whether to transfer Configuration Only, Runtime Only, or Development (both).

10. Select Yes to transfer the selected option.

11. Select the Exit menu option to exit the Security Key Utility and return to the Windows desktop.

Getting Started with MachineShop

Whether you are an experienced Interact Project Manager (IPM) user, or a new user, you should read this section before you begin to create and manage projects in MachineShop. This section explains how to read projects in MachineShop that were created in Interact Project Manager, how to get online help, and how to start MachineShop.

Reading IPM Projects in MachineShop

MachineShop was designed to replace Interact Project Manager (IPM); however, MachineShop is capable of reading projects that were created in IPM, Interact, or MachineLogic.

Note In order for MachineShop to read these projects, they must be located in the MachineShop Projects directory on your hard drive. See Chapter 3 for information about the Project Directory structure.

In fact, MachineShop will prompt you whenever you attempt to open an Interact or MachineLogic project that was not created in MachineShop. MachineShop displays the following message:

Click yes to create the associated files. After MachineShop creates the associated files, you can use MachineShop to view and download all IPM projects to the PowerStation Shell.

Important After you create the associated MachineShop files, you can still use IPM to download Interact projects to the PowerStation Shell, but you cannot use IPM to download Interact projects to the MachineShop Shell.
MachineShop can also read project backups that you created in IPM. When you restore a project backup that was created with IPM, MachineShop maintains the directory structure for Interact projects.

**Online Help**

Online Help is available if you have any questions about how to perform a particular operation or need information about the elements appearing on the screen. To access the online help, simply select Help from the MachineShop Toolbar.

There are several ways to find help in the MachineShop help file. You may view the help contents, perform an index search, or search for specific words or phrases using the Find tab in the help window.

MachineShop also provides What’s This Help. What’s This Help provides information about different elements on the screen. To use the What’s This Help for a dialog box, click the question mark in the upper right-hand corner of the dialog box and then click the element to display a popup window.

To use the What’s This Help for a menu command or toolbar button, click What’s This? on the Help menu, and then click the element to display a popup window.

**Starting MachineShop**

MachineShop is a Windows-base program designed to run in the Microsoft Windows environment.

To start MachineShop, complete the following steps:

1. Click **Start** on the Taskbar.
   
   The Start menu opens.

2. Select **MachineShop** from the Programs folder.
   
   The MachineShop folder opens.

3. Click **MachineShop Toolbar**.

   **Note** If you have a shortcut defined, double-click on the **MachineShop Toolbar** icon on your Windows desktop.
The MachineShop Toolbar and Welcome dialog appear on your screen as shown below.

The Welcome dialog is designed to guide you through the process of creating a project, opening an existing project, opening and downloading an existing project to the runtime system, and restoring a MachineShop project to the runtime system.

The Welcome dialog will display on your screen each time you start MachineShop unless you select the **Don’t display this startup screen again** box. You may turn the Welcome dialog back on at anytime by selecting the **Show welcome dialog on startup** box in the Options dialog.

**MachineShop User Interface**

The MachineShop user interface consists primarily of a toolbar that appears at the top of the Windows desktop by default. You can drag and drop the toolbar to any location on the screen.

**To drag the Toolbar to another location, complete the following steps:**

1. Position the mouse cursor over the MachineShop Toolbar.
2. Click and drag the Toolbar to the desired screen location.

You may also set the visibility of the toolbar using the Options command on the Tools menu. See *Chapter 7* to learn how to set the visibility.
**Menus**

MachineShop provides conventional Windows menus that are used to gain access to the variety of functions available in MachineShop. The commands you will use most frequently are also displayed on the toolbar.

**File Menu**

The File menu allows you to create a new project, open an existing project, and close an open project. It also allows you to delete projects and define the location where MachineShop project information will be stored.

**Edit Menu**

Enabled with open projects, the Edit menu allows you to view or modify the description of the project, and set MachineLogic Memory and Ports, I/O interface, and Runtime Target for the current project.

**View Menu**

The View menu allows you to view information about the current project. Available information includes the project name, location, description, size, as well as information specific to projects that contain Interact and/or MachineLogic. It also allows you to view a list of runtime systems that are currently connected to the development system using a MachineShop Net LAN connection.

*Note* MachineShop Net is a type of connection between development and runtime systems.

**Tools Menu**

The Tools menu allows you to create or restore backups for current projects or projects located on a remote system. It also allows you to customize and configure MachineShop. You may add, edit, or remove a suite component to MachineShop. When you add a suite component, MachineShop adds a button to the MachineShop Toolbar and a command to the Tools menu. Selecting either the command or the button launches the associated application.

See *Chapter 7* for a complete discussion on adding, editing, and removing suite components.
Chapter 2: Introducing MachineShop

MachineShop User Interface

Transfer Menu

The Transfer menu is used to download a project (and project components) to or upload a project from a remote system. It is also used to select, add, edit, or remove the connections that will be used for transferring projects between MachineShop and a remote workstation.

Window Menu

The Window menu allows you to close Interact and MachineLogic.

Help Menu

The Help menu includes the commands for finding help on MachineShop. This includes opening the help window, using the context-sensitive help, and connecting to the CTC Parker website. The Help menu also includes commands for viewing help for each of the I/O drivers supported by MachineLogic.

Toolbars

Toolbars provide quick access to the commands you use most often in MachineShop. The MachineShop Toolbar is comprised of three smaller toolbars called rebars. Rebars are individual segments of a toolbar. You can reposition the rebars within a toolbar by clicking and dragging the vertical line on the left side of the rebar to the desired location.

The three rebars on the MachineShop Toolbar are: the Project Management Rebar, the Suite Navigation Rebar, and the Transfer Rebar.

Project Management Rebar

Use the Project Management rebar to execute project-related commands that you would otherwise select from the MachineShop File, Tools, and Help menus.
Suite Navigation Rebar
Use the Suite Navigation Rebar to launch applications that you would otherwise launch from the MachineShop Tools menu or from the Windows Start menu. By default, Interact and MachineLogic are always available from this rebar if they were installed.

When you open a MachineShop project, the selected program will launch with the proper application already loaded. After you launch Interact and MachineLogic, you can select the toolbar button to quickly switch back and forth between applications.

You can easily add additional buttons to the Suite Navigation Rebar. See Chapter 7 for instructions on how to add and remove buttons.

Transfer Rebar
Use the Transfer Rebar to execute transfer-related commands that you would otherwise select from the MachineShop Transfer menu.
Managing Projects

Once you become familiar with the user interface, you can begin creating and managing projects that use Interact applications and MachineLogic projects. This chapter will show you how to create a project, open and edit a project, and view project information. It also describes the directory structure of the MachineShop projects.

Chapter Contents

- Overview of MachineShop Projects 22
- Create a New Project 24
- Open an Existing Project 29
- Save a Project 30
- Delete a Project 30
- View Project Information 31
- Edit a Project 33
Overview of MachineShop Projects

A MachineShop project is a collection of related files and applications that you create on a development system and download to a runtime system. The purpose of a project is to group all the necessary files for HMI, PC based logic control, and special user defined startup programs for a machine control application together under a single name. You can create multiple projects on the development system to maintain various configurations of a runtime system’s tasks, but only one project can reside on a runtime system at one time.

Creating a new project is very simple in MachineShop. MachineShop includes a New Project Wizard to guide you through the process of creating a project. Each project contains a specific set of files for running Interact applications and managing machine control programs.

Project Directory Structure

MachineShop stores all projects in the MachineShop subdirectory named Projects. Each project contains its own subdirectory. For example, Interact projects are created and stored in the \PROJECTS\INTERACT directory, and MachineLogic projects are created and stored in the \PROJECTS\MACHLOG directory.

The project directory structure is illustrated below:

```
C:\MACHSHOP
  \PROJECTS
    \CONFIG
    \INTERACT
      \PROJ_1
        \APPFILES
        \STARTUP
      \PROJ_2
      \PROJ_3
    \MACHLOG
      \PROJ_1
      \PROJ_3
    \TUTORIAL
```

The CONFIG directory stores the MachineLogic Runtime configuration files. The APPFILES directory stores subdirectories for each application you create for your Interact project, and the STARTUP directory stores extra AUTOEXEC.BAT files or driver system files, network initialization files, etc.

Related files and applications that you create on the development system are stored automatically in the project subdirectories.
Chapter 3: Managing Projects

Overview of MachineShop Projects

Startup Files

Your runtime system may require its own set of startup files, such as the Autoexec.bat or Config.sys files, for loading system drivers or terminate-stay-resident programs (TSRs) into memory prior to running Interact. System drivers usually have a .sys extension. A command placed in the config.sys file loads the system drivers. A command in the Autoexec.bat file loads the TSRs.

You can create your own startup files on the development system and copy these along with any needed programs, such as drivers or TSRs, into the project’s \STARTUP directory. During a project download, the development system will send these files to the runtime workstation.

Setting the Project Path

You may define the location where MachineShop projects will be stored by selecting the Project Path command from the File menu. This path is set to MACHSHOP\PROJECTS by default.

**Note** You cannot change the project path while a project is open in MachineShop.

To change the project path, complete the following steps:

1. Select the **Project Path** command from the File menu.
   
   The Project Path dialog box appears.

2. Browse to the location on your hard drive where you want MachineShop to store project files.

3. Click **OK**.
Create a New Project

You are now ready to create a project. MachineShop provides a New Project Wizard to guide you through the process.

To create a new project, complete the following steps:

1. Select the **New Project** command from the File menu or click the **New Project** button in the toolbar.

   The New Project dialog box appears.

2. Enter the name of the project.

3. Enter a project description.

4. Select the applications (Interact and/or MachineLogic) that you want to use and its runtime target. If ML is selected, go to the MachineLogic Target pull-down menu, and select a runtime target.

5. Click **OK** to accept these changes.

   The New Project Wizard appears. If MachineLogic is part of the project, then the following window appears. If MachineLogic is not part of the project, skip to step 8.

6. Select one of the templates from the list of available templates, and then click **Next**.

   **Note** With the MLSC option, MachineLogic applications can now have more than one I/O interface. You can still select a template, and then select all the I/O interfaces desired on the next screen of the New Project Wizard.
- Template for UCS DeviceNet - includes global variables and I/O configuration for a UCS DeviceNet I/O driver.
- Template for SST Profibus - includes global variables and I/O configuration for an SST Profibus I/O driver.
- Template for Simulated I/O - includes global variables and I/O configuration for simulating a MachineLogic project on your development PC.
- Template for Dummy I/O - includes global variables and I/O configuration for an application that does not communicate with I/O devices. This allows you to debug your application prior to putting the control online.
- Template for Tutorial - includes global variables and I/O configuration for the MachineLogic Tutorial.
- Other templates may be available: the Template for Enomb - includes global variables and I/O configuration for an Enomb driver.

**Note** The templates do not select the driver itself. The templates set up memory and project options.

After selecting a template, one of the following windows appears.
7. Complete one of the following:

<table>
<thead>
<tr>
<th>Runtime Target</th>
<th>Action</th>
</tr>
</thead>
</table>
| MLSC           | 1. Select each I/O interface to be used in the MachineLogic application.  
                 2. Select Add. |
|                | **Note** For the MLSC option, the wizard allows only certain combinations of interfaces: SST DeviceNet cannot be combined with SST Profibus; Modbus32 (Enomb) can be combined with either SST DeviceNet or SST Profibus but not with both. |
| MLPC           | Select the I/O interface to be used in the MachineLogic Application. |

8. Make sure the I/O interfaces match the hardware installed in the runtime system.

9. Click **Next** if Interact is part of your project. Otherwise, click **Finish** and skip to step 14.

   If Interact is part of the project, the following window appears.

10. Enter a name eight characters or less and select the display resolution for your Interact application.
11. Click **Next** to select the modules you want to use in your Interact application.

The following window appears.

12. Double-click the modules in the list that you want to use in your Interact application.

13. Click **Next** to select the drivers you want to use in your Interact application. The following window appears.

14. Double-click the drivers in the list that you want to use in your Interact application. The MachineLogic driver will already be included if you had selected MachineLogic for your new project.
15. Click **Finish** when you are finished selecting the drivers. The New Project Information dialog box appears with the options selected in the New Project Wizard.

![New Project Information Dialog Box](image)

16. Click **OK** to create the project using these options, or click **Cancel** to return to the last page of the New Project Wizard.

**Note**  If you selected MachineLogic as part of your project, make sure to set the Runtime Target on the Edit menu under the MachineLogic option (see *MachineLogic Runtime Target on page 36*).

17. Once the project is created, select the appropriate command from the Tools menu or click the appropriate button on the toolbar to launch MachineLogic or Interact.

The program will open with the proper application ready for development.
Open an Existing Project

Before developing your Interact application and/or MachineLogic project, you must open your project using the MachineShop Toolbar. Once the project is open, you can then launch Interact or MachineLogic.

**Note** Project files use the .WMS extension. Each time you select the Open Project command, MachineShop searches the project directory for Interact or MachineLogic application files that are not part of a MachineShop project. If files are found, MachineShop displays a message asking if you would like to create a MachineShop project file.

To open a project, complete the following steps:

1. Select the **Open Project** command from the File menu, or click the **Open Project** button on the toolbar.

   The Open Project dialog box appears.

2. Browse to the location on your hard drive that contains the project file.

   Project files use the .WMS extension.

3. Click **Open** to open the project.

4. Select the appropriate command from the Tools menu or click the appropriate button on the toolbar to launch Interact or MachineLogic.

   The program will open with the proper application ready for development.
Save a Project

You may save the current project to a local or network location. By default, the location is the current path setting set using the Project Path command.

To save a project, complete the following steps:

1. Select the **Save Project As** command from the File menu.

   The Save Project As dialog box appears.

2. Browse to the location on your hard drive where you want to save the project.

   Project files use the .WMS extension.

3. Enter the name of the project in the File name box.

4. Click **Save** to save the project.

Delete a Project

You may delete any existing MachineShop project from any location using the Delete Project command. The Delete Project command also deletes the Interact and MachineLogic files associated with the project as well as your startup files.

To delete a project, complete the following steps:

1. Close the project that you want to delete if it is open.
2. Select the **Delete Project** command from the File menu.

   The Delete Project dialog box appears.

   ![Delete Project dialog box](image)

3. Browse to the location on your hard drive that contains the project you want to delete.

   Project files use the .WMS extension.

4. Enter the name of the project in the File name box.

5. Click **Delete** to delete the project.

   The Confirm Project Deletion dialog box appears.

6. Click **Yes** to delete the project.

**View Project Information**

You may view information about the active project on your local system using the Project Information command. This includes startup files, Interact drivers and modules used, MachineLogic application information, and version numbers for Interact and MachineLogic development and runtime components.

**To view local project information, complete the following steps:**

1. Open the project if you haven’t already.
2. Select the **Project Information** command from the View menu or click the Project Information button on the toolbar.

The Project Information property sheet appears.

![Project Information Property Sheet]

3. Click on one of the following tabs to view the available information for this project:
   - **Project** - Displays the name of the project, the location where this project is stored, the description, and the size of the individual components of this project.
   - **Startup Files** - Displays the names of the startup files (if any) located in the startup folder of this project.
   - **Interact** - Displays the names of the modules, drivers, and Interact applications used in this project.
   - **MachineLogic** - Displays the type of target and the MachineLogic programs used in this project.
   - **Versions** - Displays the version numbers for Interact and MachineLogic development and runtime components used by this project.

   **Note** The Interact and MachineLogic tabs are available only when they are part of the project.

4. Click **OK** or **Cancel** to close the Project Information property sheet.
Edit a Project

You may edit the project description for the active project. If the project includes MachineLogic, you may use the Edit Menu - MachineLogic option to modify the I/O Interface, the Runtime Target, and the Memory and Ports assignment.

Project Description Option

Use the Project Description option on the Edit menu to view or modify the description for the current project.

To modify the project description, complete the following steps:

1. Open the project if you haven’t already.
2. Select the Project Description command from the Edit menu. The Project Description dialog box appears.

3. Enter or edit a description in the Project Description area.
4. Click OK to accept the new or modified description, or Cancel to return to the previous description.

MachineLogic Option

MachineLogic Memory and Ports

Use the Memory and Ports option to modify the MachineLogic Memory model and serial port assignment for the current project. The Memory model refers to the amount of memory reserved for the control logic program size and the amount of memory reserved for system data. Modifying Memory and Port assignments differs slightly according to the runtime target, MLPC or MLSC.

To modify the Memory and Port assignment if the runtime target is the MLPC, complete the following steps:

1. Open the project if you haven’t already.
2. Select MachineLogic from the Edit menu.
3. Select the **Memory and Ports** command from the MachineLogic menu.

When the runtime target is the MLPC, the following Memory and Ports dialog box appears.

![MLPC Memory and Ports dialog box]

4. Select the Total Memory Size you will require for your entire project in the Total Memory Size text box.

5. Select the amount of memory you will need for your program in the Program Memory text box.


7. Select the MachineLogic Output Size, in bytes.

8. Select the MachineShop Shell Operations to be enabled by checking the appropriate boxes.

9. Select the MachineLogic serial port your project will be using. Be aware that the PowerStation's COM2 port defaults to RS-485.
10. Select one of the following Options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>To accept the memory configuration.</td>
<td>Click Ok.</td>
</tr>
<tr>
<td>To lose changes and return to the previous</td>
<td>Click Cancel.</td>
</tr>
<tr>
<td>configuration.</td>
<td></td>
</tr>
<tr>
<td>To launch a detailed help topic that provides</td>
<td>Click Info.</td>
</tr>
<tr>
<td>additional memory configuration information.</td>
<td></td>
</tr>
</tbody>
</table>

11. Click OK to accept the memory configuration, click Cancel to return to the previous configuration, or click Info to launch a detailed Help topic providing additional memory configuration information.

**To modify the Memory and Port assignment if the runtime target is the MLSC, complete the following steps:**

1. Open the project if you haven’t already.
2. Select **MachineLogic** from the Edit menu.
3. Select the **Memory and Ports** command from the MachineLogic menu.

If the runtime target is the MLSC, the following Memory and Ports dialog box appears.

4. Select the Program Size, in kilobytes.
5. Select the MachineLogic Memory Size in kilobytes.
7. Select the MachineLogic Output Size, in bytes.
8. Select the Extended Flag Size, in kilobytes.
9. Select the SlotCard serial port baud Rate.

10. Select the MachineShop Shell Operations to be enabled by checking the boxes for Power Fail Enabled and/or Watchdog Enabled.

11. Click OK to accept the memory configuration, click Cancel to return to the previous configuration, or click Info to launch the MachineLogic Memory Model help topic providing additional memory configuration information.

**MachineLogic I/O Interface**

Use the I/O Interface selection to view or modify the MachineLogic I/O interface(s) for the current project. The I/O interface refers to the hardware and software that is necessary to communicate between a PC running MachineLogic and a device or machine that is being controlled by that PC.

**To modify the I/O interface, complete the following steps:**

1. Open the project if you haven’t already.

2. Select MachineLogic from the Edit menu.

3. Select the I/O Interface command from the Edit menu.

4. For the MLPC option, select one I/O interface from the list of available interfaces. For the MLSC option, select the interface(s) you wish to remove or add, and press Remove or Add.

   **Note** For the MLSC option, only certain combinations of interfaces are allowed: SST DeviceNet cannot be combined with SST Profibus; Modbus32 (Enomb) can be combined with either SST DeviceNet or SST Profibus but not with both.

5. Click OK to accept the new I/O interface(s) or Cancel to return to the previous interface(s).

**MachineLogic Runtime Target**

Use the Runtime Target command on the Edit menu to view or modify the MachineLogic runtime for the current project. This option allows you to switch runtime targets between the MLPC option and the MLSC option.
To modify the Runtime target, complete the following steps:

1. Open the project if you haven’t already.
2. Select MachineLogic from the Edit menu.
3. Select the Runtime Target command from the Edit menu.
   The Select MachineLogic Target dialog box appears:

4. Click the arrow on the pull-down menu and select either MLPC or MLSC (Slot Card).
5. Click OK to accept the new Runtime, or click Cancel to return to the previous Runtime.
Chapter 4

Adding Connections

Before you can transfer files to the runtime system, you must create a transfer connection in MachineShop. A connection refers to the method used to transfer files to or from a runtime system.

MachineShop supports four methods for transferring files between a development system and a runtime system: MachineShop Net (LAN/Serial), disk, IPM Compatible (Serial), and Direct Serial.

The MachineShop Network connection allows you to communicate with a runtime system using a Direct Serial cable, an IPM Compatible Serial cable, Ethernet Point-to-Point, or over a LAN.

Multiple connections can be defined for different types of connections. Connections can even be defined with the same connection type, but for different target runtime systems.

This chapter provides instructions on how to set up MachineShop Network Connections for a LAN, serial, Ethernet Point-to-Point, and MachineShop Direct Serial connection. It also describes how to add an IPM Compatible Serial and disk transfer connection.

Chapter Contents

- MachineShop Direct Serial Communication 40
- MachineShop Net Connections 41
- IPM Compatible Connection 61
- Disk Transfer Connection 63
MachineShop Direct Serial Communication

Direct Serial communication supports communication between a development system and a runtime system that are connected to each other by a Null modem serial cable.

The Direct Serial connection is designed to provide a simple method for users to transfer MachineShop project files from a development to a runtime system. It supports serial communications to the MachineShop Shell for projects including MachineLogic and Interact or to the PowerStation Shell for projects developed in Interact.

PowerStation Shell serial communications use the same protocol as Interact Project Manager (IPM).

To add a Direct Serial connection in MachineShop, complete the following steps:

1. Open MachineShop.
2. Select the Add Connection command from the Transfer Menu or click the Add Connection button on the toolbar.
   The New Connection dialog box appears.
3. Select Direct Serial as the connection type.
4. Enter a name for this connection.
5. Click OK to accept these choices.
Chapter 4: Adding Connections

MachineShop Net Connections

The New Connection Wizard appears.

6. Select the COM port and baud rate you will be using in this connection.

7. Click Finish to create the connection.

MachineShop Net uses the TCP/IP protocol to communicate between a development system and a runtime system through a LAN, Dialup Networking, or a PPP serial connection. CTC chose this protocol because it is the primary communications protocol being used today. As its name implies, this is the same protocol that is the basis for Internet communications—email (SMTP), file transfer (FTP), and most notably, the World Wide Web (HTTP).

While the Local Area Network (LAN) uses an Ethernet patch cable to connect a development system and a runtime system, Dialup Networking and PPP Serial uses a serial cable.

Additionally, serial and modem connections require Dial-Up Networking, and an Ethernet point to point connection requires you to configure the Ethernet card’s TCP/IP properties.

LAN communications are the preferred method of net communication because they offer the fastest transfer rates and the greatest flexibility.

This section describes how to add MachineShop Net connections for a LAN, Ethernet point to point, serial, and modem connection.
LAN Connection

Using the MachineShop Net connection you can connect a development system to a runtime system through a Local Area Network (LAN). LAN communications are the preferred method of communication because they offer the fastest rates and the greatest flexibility.

To add a LAN connection in MachineShop, complete the following steps:

1. Open MachineShop.
2. Select the Add Connection command from the Transfer Menu or click the Add Connection button on the toolbar.
   The New Connection dialog box appears.

   ![New Connection Dialog Box]

3. Enter a name for this connection.
4. Select MachineShop Net (Serial/LAN) as the connection type.
5. Click **OK** to accept these choices.

   The New Connection Wizard appears.

6. Select **LAN** as the network connection type.

7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.

   The Network Details dialog box appears.
8. Select one of the following options:

- **IP Address** - Select this option to specify the IP address of a runtime system. Enter the IP address in the top box of the Name group.

- **MachineShop Net Name** - Select this option to specify a runtime system by name. This is the name you entered using the MachineShop Shell/Settings/TCP/IP/Net Name command.

  MachineShop automatically displays the names that it is able to detect in the list box. Select a name from the list.

  **Note** The runtime system must be configured and connected for it to appear in the MachineShop Net Name list.

- **Host Name** - Select this option to specify the host name, such as www.ctcusa.com, of the runtime system. This option requires a network with a domain name server (DNS). Your network administrator must also configure a host name to match the IP address of the runtime system prior to using this option.

9. Click **OK** to accept these choices.

   You are returned to the New Connection Wizard.

10. Click **Next** to continue.

   The following window appears.
11. Enter a user name and password only if an FTP user name and password was entered on the runtime system.

The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Select **Yes** to enable passive transfers. Otherwise, select **No**.

Passive transfers allow MachineShop to connect to an FTP server when the MachineShop Toolbar is behind a firewall. In most cases, you will NOT need passive transfers.

13. Click **Finish** to create the connection.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit command from the Transfer menu.

**Ethernet Point to Point Connection**

Using the MachineShop Net connection you can connect a development system to a runtime system through an Ethernet patch cable. In addition to adding the connection in MachineShop, you must configure the TCP/IP properties for the Ethernet card.

This section describes how to configure the TCP/IP properties and add the connection in MachineShop. For configuration in Windows NT, skip to page 48. For configuration in Windows 2000, skip to page 51.

**Configure TCP/IP Properties in Windows 95/98**

Use the Network option in the Windows Control Panel to configure the Ethernet card’s TCP/IP properties.

**Note** You may be asked to insert Windows installation disk(s) or CD-ROM after making the adjustment.
To configure the TCP/IP properties in Windows 95/98, complete the following steps:

1. Double-click the **Network** icon in the Windows Control Panel.

   The Network control property sheet appears.

   ![Network Control Property Sheet](image)

2. Click the **Configuration** tab if it is not already in view.

   The Configuration tab appears.
3. Select the TCP/IP network component for your Ethernet card from the list of components and then click **Properties**. The TCP/IP property sheet appears.

![TCP/IP Properties](image)

4. Click the **IP Address** tab if it is not already in view. The IP Address tab appears.

5. Select **Specify an IP Address** and then enter the IP address and IP mask for the development system.

   CTC recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP mask.

   **Note**  If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.
6. Click the **Advanced** tab.

The Advanced tab appears.

7. Select **Set this protocol to be the default** at the bottom of the screen.

8. Click **OK** to accept these choices.

The Network control property sheet appears.

9. Click **OK** to exit the Network control property sheet.

You are now ready to add the connection in MachineShop. See *Add Connection in MachineShop* on page 52 for instructions.

**Configure TCP/IP Properties in Windows NT**

Use the Network option in the Windows Control Panel to configure the Ethernet card’s TCP/IP properties.

**To configure the TCP/IP properties in Windows NT, complete the following steps:**

1. Double-click the **Network** icon in the Windows Control Panel.
The Network control property sheet appears.

![Network control property sheet](image1)

2. Click the **Protocols** tab.

The Protocol tab appears.

![Protocol tab](image2)
3. Select **TCP/IP Protocol** from the list of Network Protocols and then click **Properties**.

The Microsoft TCP/IP property sheet appears.

4. Click the **IP Address** tab if it is not already in view.

The IP Address tab appears.

5. Select the Ethernet adapter for your card from the list of adapters.

6. Select **Specify an IP address** and then enter the IP address and IP mask for the development system.

   CTC recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP mask.

   **Note**  If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

7. Click **OK** to accept these choices.

The Network control property sheet appears.
8. Click **OK** to exit the Network property sheet.

You are now ready to add the connection in MachineShop. Please skip to page 52.

**Configure TCP/IP Properties in Windows 2000**

Use the Network and Dial-Up Connections option in the Windows Control Panel to configure the Ethernet card’s TCP/IP properties.

**Note** You may be asked to insert Windows installation disk(s) or CD-ROM after making the adjustment.

To configure the TCP/IP properties in Windows 2000, complete the following steps:

1. Double-click the **My Computer** icon on the desktop and then double-click the **Control Panel** folder and then double-click the **Network and Dial-Up Connections** folder.

2. Right-click the Local Area Connection and then select **Properties**.

The Local Area Connection Properties sheet appears.
3. Select Internet Protocol and click on **Properties**.

The Internet Protocol Properties window appears:

4. Select **Use the following IP Address** and then enter the IP address and IP mask for the development system.

CTC recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP mask.

**Note** If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

5. Click **OK** to accept these choices.

The Network control property sheet appears.

6. Click **OK** to exit the Network control property sheet.

You are now ready to add the connection in MachineShop.

**Add Connection in MachineShop**

Once you have configured the TCP/IP properties for the Ethernet card, you can add the connection in MachineShop.
To add an ethernet point to point connection in MachineShop, complete the following steps:

1. Open MachineShop.

2. Select the **Add Connection** command from the Transfer menu.

   The New Connection dialog box appears.

3. Enter a name for this connection.

4. Select **MachineShop Net (Serial/LAN)** as the connection type.

5. Click **OK** to accept these choices.

   The New Connection Wizard appears.

6. Select **LAN** as the network connection type.
7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system. The Network Details dialog box appears.

8. Select **IP Address** and then enter the IP address of the runtime system in the top box of the Name group. Typically the IP address for the runtime system is 10.0.0.2.

9. Click **OK** to accept your entries and return to the New Connection Wizard.

10. Click **Next** to continue.

   The following window appears.
11. Enter a user name and password only if an FTP user name and password was entered on the runtime system.

The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Click **Finish** to create the connection.

13. Connect the development system to the Ethernet connector using a cross-over 10Base-T cable.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.

---

**MachineShop Net PPP Connection**

Using the MachineShop Net Point to Point connection you can connect the development system to a runtime system using a serial cable with hardware handshaking. MachineShop uses a specific dial-up entry named “MachineShop Phonebook Entry” to communicate with the runtime system. The MachineShop Phonebook Entry is created when you install MachineShop. For details on the MachineShop installation program, see the *MachineShop Installation Booklet*.

To add a Net Point to Point connection in MachineShop, complete the following steps:

1. Open MachineShop.

2. Select the **Add Connection** command from the Transfer menu or click the **Add Connection** button on the toolbar.

The New Connection dialog box appears.

3. Enter a name for this connection.
4. Select **MachineShop Net (Serial/LAN)** as the connection type.

5. Click **OK** to accept these choices.

The New Connection Wizard appears.

6. Select **PPP Serial** as the network connection type.

**Note** This option uses a specific dial-up entry named “MachineShop Phonebook Entry”. This entry should have been created by the MachineShop installation program.

If the installation program could not create the MachineShop Phonebook Entry, the Direct Connection option will not be available. See **Appendix A** for instructions on how to manually create the MachineShop Phonebook Entry.
7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.

The Network Details dialog box appears.

8. Select **IP Address** and then enter the IP address of the runtime system in the top box of the Name group.

Typically the IP address for the runtime system is 10.0.0.2.

9. Click **OK** to accept these choices.

You are returned to the New Connection Wizard.

10. Click **Next** to continue.

The following window appears.
11. Enter a user name and password only if an FTP user name and password was entered on the runtime system.

The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Click Finish to create the connection.

13. Connect the serial cable to the appropriate serial port of the development system.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.

**Modem Connection**

The MachineShop Net Connection also allows a remote computer to connect to a runtime system through a modem. This connection uses Windows Dial-Up Networking to dial into a LAN-based remote access server.

You must configure Dial-Up Networking in order to dial into the remote access server. Dial-Up Networking is available from the My Computer icon on the Windows desktop. Once you have created and configured the dial-up connection, you can add the connection in MachineShop.

**To add a modem connection in MachineShop, complete the following steps:**

1. Open MachineShop.

2. Select the **Add Connection** command from the Transfer menu or click the **Add Connection** button on the toolbar.

The New Connection dialog box appears.
3. Enter a name for this connection.

4. Select **MachineShop Net (Serial/LAN)** as the connection type.

5. Click **OK** to accept these choices.

   The New Connection Wizard appears.

![New Connection Wizard - Network - Step 1](image)

6. Select **Dial-Up Networking** as the network connection type and then select the dial-up entry from the list box.

   The list box displays the available dial-up entries that you can associated with this connection. These entries are created using Windows Dial-Up Networking available from the My Computer icon on the Windows desktop. See **Appendix A** for instructions on creating and configuring a MachineShop dial-up connection.
7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.

The Network Details dialog box appears.

8. Select **IP Address** and then enter the IP address of the runtime system in the top box of the Name group.

This is the IP address of the runtime system assigned by the network. Check with your local network administrator to determine a valid IP Address to be used on your local network.

9. Click **OK** to accept your entries.

You are returned to the New Connection Wizard.

10. Click **Next** to continue.

The following window appears.
11. Enter a user name and password only if an FTP user name and password was entered on the runtime system. The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Select **Yes** to enable passive transfers. Otherwise, select **No**. Passive transfers allow MachineShop to connect to an FTP server when the MachineShop Toolbar is behind a firewall. In most cases, you will NOT need passive transfers.

13. Click **Finish** to create the connection.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.

---

**IPM Compatible Connection**

The Interact IPM Compatible Serial connection is used to transfer projects to a CTC PowerStation that has the PowerStation Shell installed on it. This connection supports the transfer of Interact projects only, and is supplied for backward compatibility with existing systems. The Interact IPM Compatible connection uses a serial port connection between the MachineShop development system and the PowerStation.

**Note** This connection replaces IPM connectivity. IPM is a DOS based utility that is optimized for handling serial ports and the transfer of files through them. This connection will provide the same capability as IPM. Due to the addition of overhead in handling of serial ports in the Windows environment, the length of time necessary to transfer files with this connection may increase from the transfer times when using IPM.

**To add an Interact IPM Compatible connection, complete the following steps:**

1. Open MachineShop.
2. Select the **Add Connection** command from the Transfer menu or click the **Add Connection** button on the toolbar.

The New Connection dialog appears.

3. Enter a name for this connection.

4. Select **IPM Compatible (Serial)** as the connection type.

5. Click **OK** to accept these choices.

   The New Connection Wizard appears.

6. Select the COM port and baud rate you will be using in this connection.

7. Click **Finish** to create the connection.

You are now ready to transfer Interact projects to a CTC PowerStation that has the PowerStation Shell installed on it. See *Chapter 6* for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.
Disk Transfer Connection

Disk communications include communications between a development system and a mass storage device. Examples include internal and external hard drives, floppy drives, Zip drives, tape drives, network drives, Compact Flash readers, etc. The mass storage device must be mapped to a specific drive letter from A to Z.

To add a disk transfer connection, complete the following steps:

1. Open MachineShop
2. Select the **Add Connection** command from the Transfer menu or click the **Add Connection** button on the toolbar.

   The New Connection dialog box appears.

   ![Add Connection dialog box](image)

3. Enter a name for this connection.
4. Select **Disk** as the connection type.
5. Click **OK** to accept these choices.

The New Connection Wizard appears.

6. Select the letter of the drive you will be using in this connection.

   You may select any removable drive such as a floppy drive, Compact FLASH, or Zip drive.

7. Click **Finish** to create the connection.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See *Chapter 3* for details on creating projects and *Chapter 6* for details on transferring files.

If you need to make changes to the connection, simply select the Edit Connection command from the Transfer menu.
Chapter 5

Backing Up Projects

MachineShop provides a wizard for backing up and restoring projects to and from runtime workstations or a variety of storage devices (diskette, Compact Flash, hard drive, network, etc.). This chapter describes how to create and restore a project backup for a current project or a project located on a runtime system. It contains both descriptive information and step-by-step instructions.

Chapter Contents

- Creating a Backup 66
- Restoring a Backup 69
Creating a Backup

MachineShop provides a Backup Wizard to guide you through the process of backing up a local project or a project on a runtime system to a selected target. The target can be a variety of storage devices including diskette, Compact Flash, hard drive, or network.

Projects are compressed into a subdirectory with the same name as the project. After the project is backed up, the file names are appended with a .zip suffix.

Local Project Backup

You may backup the current project on the development system using the Project command from the Create Backup submenu. This command will launch the Backup Wizard.

To backup a local project, complete the following steps:

1. Open the project if you haven’t already.
2. Select the Create Backup command from the Tools menu.
   
   The Create Backup submenu appears.
3. Select the Project command from the Create Backup submenu.
   
   The Backup Wizard appears.
4. Enter the full path including the drive letter where you want to store this backup.
5. Select the components that you want to include in the backup:
   - Runtime Program Files - includes the Interact and MachineLogic runtime program files.
   - Application Files - includes the Interact and MachineLogic application files in the backup.
   - MachineLogic Source - includes the zip (.ZWT) file of the MachineLogic source files in the backup.

6. Click **Finish**.

The Backup Project Information window appears.

7. Click **OK** to backup the active project on the development system.

   The Backing Up dialog box appears.

8. Click **Close** when the backup operation is done.
Remote Project Backup

You may backup an active project on a runtime system using the Remote System command from the Create Backup submenu. This command will launch the Backup Wizard.

**Note**  You must create the connection you plan to use to communicate with the runtime system before you can create the remote project backup. See Chapter 4 for information on adding connections.

**Important**  You can only back up projects on the runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

To backup a project on a runtime system, complete the following steps:

1. Select the connection you want to use from the Select Connection box on the MachineShop Toolbar.
2. Select the Create Backup command from the Tools menu.

   The Create Backup submenu appears.
3. Select the Remote System command from the Create Backup submenu.

   The Backup Wizard appears.

4. Enter the full path including the drive letter where you want to store this backup.
5. Select the components that you want to include in the backup:
   - Runtime Program Files - includes the Interact and MachineLogic runtime program files.
   - Application Files - includes the Interact and MachineLogic application files in the backup.
   - MachineLogic Source - includes the zip (.ZWT) file of the MachineLogic source files in the backup.

6. Click Finish to backup up the project on the runtime system.
   The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

7. Click Close when the backup operation is done.

Restoring a Backup

MachineShop provides a Restore Wizard to guide you through the process of restoring a project backup to either the development or runtime system. The backup may be located on a variety of storage devices including diskette, Compact Flash, hard drive, or network.

Restore Backup to the Local System

You may restore a project from a selected source to the development system using the Project command from the Restore Backup submenu. This command will launch the Restore Wizard. The Restore Wizard will automatically decompress the backup and restore it to the location set in the Project Path dialog box.

To restore a project backup to the development system, complete the following steps:

1. Select the Restore Backup command from the Tools menu.
   The Restore Backup submenu appears.
2. Select the **Project** command from the Restore Backup submenu.

   The Restore Wizard appears.

![Restore Wizard - Step 1](image1)

3. Enter the full path including the drive letter where the backup is stored.

4. Select the project you want to restore from the list of project backups.

5. Click **Next**.

   The following window appears.

![Wizard - Step 2 of 2](image2)
6. Select the components of the project that you want to include in the restoration and then click Finish.

   The Restore Project Information window appears.

   ![Restore Project Information Window]

7. Click OK to restore the project on the development system.

   The Restore dialog box appears.

   Note If there is a current project with the same name as the project backup, the Restore Project dialog box appears. The Restoration process will delete the current project before it restores the backup. To continue the restoration process, click Restore. To rename the current project first, click Rename, or to exit the restoration process, click Cancel.

8. Click Close when the restore operation is done.

   **Restore Project to a Remote System**

   You may restore a project backup from a selected source to a runtime system using the Remote System command from the Restore Backup submenu. This command will launch the Restore Wizard. The Restore Wizard will automatically decompress the project backup and load it on the runtime workstation.

   **Important** You can only restore backup projects to the runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.
Note You must create the connection you plan to use to communicate with the runtime system before you can restore a project to it. See Chapter 4 for information on adding connections.

To restore a project backup to a runtime system, complete the following steps:

1. Select the connection you plan to use from Select Connection box on the MachineShop Toolbar.

2. Select the Restore Backup command from the Tools menu. The Restore Backup submenu appears.


4. Enter the full path including the drive letter where the backup is stored.

5. Select the project you want to restore from the list of project backups.
6. Click **Next**.
   The following window appears.
   ![](image1)

7. Select the components of the project that you want to include in the restoration and then click **Finish**.
   The Restore Remote Information window appears.
   ![](image2)

8. Click **OK** to restore the project on the runtime system.
   The Transferring dialog box appears on the screen. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

9. Click **Close** when the restore operation is done.
Transferring Projects

Once an application has been developed and a connection created, you can transfer the files needed to create or update a runtime system. MachineShop provides a Transfer Wizard to step you through the process of selecting a connection and transferring the files to and from a runtime system.

This chapter provides instructions on how to download and upload an active project from the development system to a runtime system. This includes using the Transfer Wizard and the Download and Upload commands.

Chapter Contents

- Downloading a Project 76
- Uploading a Project 80
Downloading a Project

Downloading refers to the process of transferring project files from a development system to a runtime system. There are two ways to download files in MachineShop: the Transfer Wizard and the Download command. This section describes how to use the two methods to download files to the runtime system.

**Important** You can only download project files to a runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

**Transfer Wizard**

The Transfer Wizard steps you through the process of selecting the transfer connection and downloading the project files to a runtime system.

**To download a project to a runtime system using the Transfer Wizard, complete the following steps:**

1. Open the project if you haven’t already.
2. Select the **Transfer Wizard** command from the Transfer menu.

   The Transfer Wizard appears.

3. Select **Download to Runtime** to download the project to the runtime system.
4. Click **Next** to continue.
5. Select the connection you want to use to transfer the files from the list of connections.
You may also create a connection from here. Click **Define New Connection** and follow the instructions provided by the New Connection Wizard. See *Chapter 4* for more information on how to add a new connection.

**Note** You now have the option of having a direct serial connection, called MachineShop Direct Serial.

6. Click **Next** to continue.

The following window appears.

7. Select **Complete Project** to download the entire project to the runtime system.

   If you do not want to download the entire project, clear the Complete Project check box; then select the files you want to download from the Components group box.

8. Choose one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>To reboot the runtime workstation after the download</td>
<td>Select the <strong>Reboot after download</strong> checkbox.</td>
</tr>
<tr>
<td>To Transfer files to the MLSC card</td>
<td><strong>Note</strong> MLSC must be included in the current project. Select <strong>Download to MachineLogic Slot Card</strong>.</td>
</tr>
</tbody>
</table>
9. Select **All Files** to download all files or **Update Files Only** to download only the files that have changed since the last download.

10. Click **Finish** to download the project files to the runtime system.

The Transferring dialog appears. It displays the file being transferred, the direction of the transfer, and the estimated time remaining.

**Download Command**

You can also use the Download command to download project files on the development system to a runtime system.

**Note** You must create the connection you plan to use to communicate with the runtime system before you can use the Download command. See Chapter 4 for information on adding connections.

**To download a project to the runtime system using the Download command, complete the following steps:**

1. Open the project if you haven’t already.
2. Select the connection you want to use to transfer the files from the Select Connection box on the toolbar.
3. Select the **Download** command from the Transfer menu or click the **Download** button on the toolbar.

The Download dialog box appears.
4. Select **Complete Project** to download the entire project to the runtime system.

If you do not want to download the entire project, clear the Complete Project check box; then select the files you want to download from the Components group box.

5. Select **All Files** to download all of the files or **Update Files Only** to download only the files that have changed since the last download.

6. Choose one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>To reboot the runtime workstation after the download</td>
<td>Select the Reboot after download checkbox.</td>
</tr>
<tr>
<td>To Transfer files to the MLSC card</td>
<td>Note MLSC must be included in the current project.</td>
</tr>
<tr>
<td></td>
<td>Select Download to MachineLogic Slot Card.</td>
</tr>
</tbody>
</table>

7. Click **Download** to download the project files to the runtime system.

The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.
Uploading refers to the process of transferring a project from a runtime system to a development system. Like Downloading, there are two ways to upload files in MachineShop: the Transfer Wizard and the Upload command. This section describes how to use the two methods to upload project files from the runtime system.

Important You can only upload project files from a runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

Transfer Wizard

The Transfer Wizards steps you through the process of selecting the transfer connection and uploading the project files from the runtime system.

To upload a project from the runtime system using the Transfer Wizard, complete the following steps:

1. Select the Transfer Wizard command from the Transfer menu.

   The Transfer Wizard appears.

   ![Transfer Wizard screenshot]

2. Select Upload from Runtime to upload the project.
3. Click **Next** to continue.

The following window appears.

4. Select the connection you want to use to transfer the files from the list of connections.

Or click **Define New Connection** and follow the instructions provided.

See *Chapter 4* for more information on how to add a new connection.

You now have the option of having a direct serial connection, called Direct Serial.

5. Click **Next** to continue.

6. The following window appears.
7. Select **Complete Project** to upload the entire project to the runtime system.
   
   If you do not want to upload the entire project, clear the Complete Project check box; then select the files you want to upload from the Components group box.

8. Select **All Files** to upload all of the files or **Update Files Only** to upload only the files that have changed since the last upload.

9. Click **Finish** to upload the project files from the runtime system.

   The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

**Upload Command**

You may also use the Upload command to upload files from the runtime system to the development system.

**Note** You must create the connection you plan to use to communicate with the runtime system before you can use the Upload command. See Chapter 4 for information on adding connections. You now have the option of having a direct serial connection, called MachineShop Direct Serial.

**To upload a project from the runtime system using the Upload command, complete the following steps:**

1. Select the connection you plan to use to transfer the files from Select Connection box on the toolbar.
2. Select the **Upload** command from the Transfer menu or click the **Upload** button on the toolbar.

   The Upload dialog box appears.

   ![Upload Dialog Box]

3. Select **Complete Project** to upload the entire project to the runtime system.

   If you do not want to upload the entire project, clear the Complete Project check box; then select the files you want to upload from the Components group box.

4. Select **All Files** to upload all of the files or **Update Files Only** to upload only the files that have changed since the last upload.

5. Click **Upload** to upload the project files from the runtime system.

   The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.
Chapter 7

Customizing MachineShop

You may customize some of the basic MachineShop operations to suit your needs. This chapter describes how to add frequently used programs to MachineShop, set the visibility of MachineShop on the desktop, and reposition the toolbars.

Chapter Contents

Set the Visibility 86
Move the MachineShop Toolbars 87
Add, Edit, and Remove Suite Components 88
Set the Visibility

You may determine how MachineShop will appear on your
desktop. You may have the MachineShop Toolbar visible at all
times or you may have the toolbar automatically hide whenever
the mouse pointer is outside the region occupied by the toolbar.

You set the visibility options using the Options command from the
Tools menu.

To set the visibility of MachineShop, complete the following
steps:

1. Select the **Options** command from the Tools menu.

   The Options dialog box appears.

   ![Options dialog box]

2. Select **Always on Top** to keep MachineShop on top of all
   applications.

   **Note** This option is checked by default and only available when
   the MachineShop Toolbar is undocked.

3. Select **AutoHide** to hide MachineShop until you move the
   mouse into the region occupied by the MachineShop Toolbar.

   **Note** This option is cleared by default and is only available when
   the MachineShop Toolbar is docked.

4. Click **OK** to accept these choices.
Move the MachineShop Toolbars

MachineShop is docked to the top of the Windows desktop by default. You may undock the toolbar by simply dragging it away from the edge. Once the toolbar is undocked, you can move it anywhere on the screen.

To undock the MachineShop Toolbar, complete the following step:
1. Position the mouse cursor over the MachineShop Toolbar.
2. Click and drag the toolbar away from the edge of the Windows desktop.

The toolbar appears as shown below.

To dock the MachineShop Toolbar, complete the following steps:
1. Position the mouse cursor over the MachineShop title bar.
2. Click and drag the toolbar to the top of the Windows desktop.

The toolbar snaps into place along the length of the screen edge.

Move the MachineShop Rebars

The MachineShop Toolbar includes three smaller toolbars called rebars. These rebars can be repositioned on the toolbar by clicking and dragging the small handlebars.

To move the MachineShop rebars, complete the following steps:
1. Position the mouse cursor over the handlebar of the rebar you want to move.
2. Click and drag the rebar to the desired position.
Add, Edit, and Remove Suite Components

You can add, edit, and remove frequently used programs to MachineShop. Once the program is added, you can then launch the program by clicking on the button on the MachineShop Toolbar, or by selecting the command from the Tools menu.

This section describes how to add, edit, and remove programs from MachineShop.

Add a Program

You can add a program to MachineShop using the Add Suite Component command. After you add a program, you will be able to launch the program by clicking on a button on the MachineShop Toolbar or by selecting a command from the Tools menu.

To add a program to MachineShop, complete the following steps:

1. Select the Add Suite Component command from the Tools menu.
   
The Add Suite Component dialog box appears.

2. Browse to the location on your hard drive that contains the file you want to add.
   
This can be any type of file, for example, an executable (.EXE) file, an Excel (.XLS) file, the configuration file for your I/O driver, etc.

3. Click Open to accept this choice.
**Edit a Program**

You can edit a program on the MachineShop toolbar using the Edit Suite Component command. By editing a program, you will be able to add the capability to pass the program a command line argument when the program launches.

**To edit a program on the MachineShop toolbar, complete the following steps:**

1. Select the **Edit Suite Component** command from the Tools menu.

   The Edit Suite Component dialog box appears.

2. Highlight the icon for the suite component you want to edit.

3. Select the Edit button.

   The Suite Component Properties dialog box appears.

4. In the Command Line text box, enter a command line parameter that will be passed to the application when it is launched.

5. Select the For this Project Only check box if you wish the button to be local to the current project.
Application buttons are global when first added to the Toolbar. The command line parameter will be stored in the current project’s .WMS file.

6. Click **OK** to accept the selections.

**Remove a Program**

You can remove a program from the MachineShop that you previously added using the Add Suite Component command. MachineShop removes the associated button and menu command.

To remove a program from MachineShop, complete the following steps:

1. Select the **Remove Suite Component** command from the Tools menu.

   The Remove Suite Component dialog box appears.

2. Select the icon for the program you want to remove.

3. Click **Remove** to accept this choice.
Appendix A

MachineShop Dial-Up Networking Connections

This appendix describes how to create and configure dial-up networking connections for MachineShop. Configuration is necessary only for MachineShop Point-to-Point-Protocol.

Note: Configuration is NOT required for MachineShop Direct Serial connection.

Dial-Up Networking is available from the My Computer icon on the Windows desktop.

Note: If you need to modify the TCP/IP settings or the modem’s baud rate for a dial-up connection, see the Configure the Connection sections in this appendix. Windows 95/98 instructions start on page 93, Windows NT instructions start on page 99, and Windows 2000 instructions start on page 104.

95/98 Dial-Up Networking

This section describes the steps to create and configure a dial-up connection in Windows 95/98. See Windows NT Dial-Up Networking in this appendix for Windows NT instructions page 97, and Windows 2000 Dial-Up Networking in this appendix for Windows 2000 instructions page 102.

Create a Dial-Up Connection in Windows 95/98

The connection stores the settings needed to connect to the runtime system.

To create a dial-up connection in Windows 95/98, complete the following steps:

1. Double-click the My Computer icon on the desktop and then double-click the Dial-Up Networking folder.

The Dial-Up Networking window appears.
2. Double-click the **Make New Connection** icon.
   The Make a New Connection Wizard appears.

   ![Add Connection Window](image)

3. Enter the name of the computer you are dialing.
   **Important**  The name must be “MachineShop Phonebook Entry” if you are using the Direct Connection (Serial) option in MachineShop.

4. Select **MachineShop Direct Connection** as the modem.
5. Click **Next**.
   The following window appears.

   ![Make New Connection Window](image)
6. Enter “1” as the telephone number and then click **Next**.

The following window appears.

![Make New Connection window](image)

7. Click **Finish** to save the phonebook entry.

**Configure the Connection in Windows 95/98**

Now you need to configure the newly created connection.

To configure the connection, complete the following steps:


The Dial-Up Networking window appears.

![Dial-Up Networking window](image)
2. Right click on the icon for the newly created connection and then select Properties. The property sheet for the selected connection appears.

3. Clear the **Use area code and Dialing Properties** check box on the General tab.

4. Click **Configure** to set the baud rate for the MachineShop Direct Connection. The MachineShop Direct Connection property window appears.
5. Select the speed that the modem will use to transfer data from the maximum speed list. The default is 115200. This selection must match the baud rate set in the MachineShop Shell.

   **Note** If you are having reliability problems using the selected speed, try selecting a slower speed.

6. Click **OK** to accept these choices.

   The property sheet for the selected connection appears.

7. Click the **Server Types** tab.

   The Server Types tab appears.
8. Clear all check boxes except the **TCP/IP** check box and then click **TCP/IP Settings** to configure the IP address.

The TCP/IP Settings window appears.

![TCP/IP Settings Window]

9. Select **Specify an IP address** and then enter the IP address for the development system.

   CTC recommends that you enter 10.0.0.1 as the IP address for the development system.

   **Note** If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

10. Select **Specify name server addresses**.

    Make sure all the addresses are set to 0.0.0.0.

11. Clear the **Use IP header compression** and **Use default gateway on remote network** check boxes.

12. Click **OK** to accept these choices.

    The property sheet for the selected connection appears.

13. Click **OK** to exit the property sheet.
Windows NT Dial-Up Networking

This section describes the steps to create and configure a dial-up connection in Windows NT. See Windows 95/98 Dial-Up Networking in this appendix for Windows 95/98 instructions page 91, and Windows 2000 Dial-Up Networking in this appendix for Windows 2000 instructions page 102.

Create a Dial-Up Connection in Windows NT

The phonebook entry will store the settings needed to connect to the runtime system. The phonebook entry is created using Windows Dial-Up Networking.

To create a phonebook entry in Windows NT, complete the following steps:

1. Double-click the My Computer icon on the desktop and then double-click the Dial-Up Networking folder.

   If there are no previous phonebook entries, the message “The phonebook is empty” appears.

   **Note** If a phonebook entry already exists, the Dial-Up Networking window appears. Click New to add a new entry and skip to step 3.

2. Click Yes to add an entry.

   The New Phonebook Entry Wizard appears.

   ![New Phonebook Entry Wizard](image)

   **Important** The name must be “MachineShop Phonebook Entry” if you are using the Direct Connection (Serial) option in MachineShop.
3. Enter a name for the new phonebook entry and then click **Next**.
The Server window appears.

4. Select **Send my plain text password if that’s the only way to connect** and then click **Next**.
The Phone Number window appears.

5. Enter “1” as the phone number and then click **Next**.
The New Phonebook Entry Wizard appears.

6. Click **Finish** to save the phonebook entry.
The Dial-Up Networking window appears with the new phonebook entry displayed in the Phonebook entry to dial box.
Configure the Connection in Windows NT

Now you need to configure the phonebook entry.

To configure the phonebook entry, complete the following steps:


   The Dial-Up Networking window appears.

2. Select the **phonebook entry** from the Phonebook entry list.

3. Click **More** and then select **Edit entry and modem properties**.

   The Edit Phonebook Entry property sheet appears.
4. Click **Configure** on the Basic tab to set the baud rate for the MachineShop Direct Connection.

   The Modem Configuration dialog box appears.

   ![Modem Configuration dialog box](image)

5. Select the speed that modem will use to transfer data from the initial speed list.

   The default is 115200. This selection must match the baud rate set in the MachineShop Shell.

   **Note** If you have reliability problems using the selected speed, try selecting a slower speed.

6. Click **OK**.

   The Edit Phonebook Entry property sheet appears

7. Click the **Server** tab.

   The Server tab appears.

   ![Edit Phonebook Entry property sheet](image)
8. Clear all check boxes except the TCP/IP check box and then click TCP/IP settings to configure the IP address.

The TCP/IP Settings window appears.

![TCP/IP Settings Window]

9. Select Specify an IP address and then enter the IP address for the development system. CTC recommends that you enter 10.0.0.1 as the IP address for the development system.

Note If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

10. Select Specify name server addresses.

Make sure all the addresses are set to 0.0.0.0.

11. Clear the Use IP header compression and Use default gateway on remote network check boxes.

12. Click OK to accept these choices.

The Edit Phonebook Entry property sheet appears.

13. Click OK to exit the Edit Phonebook Entry property sheet.
Appendix A: MachineShop Dial-Up Networking Connections

Windows 2000 Dial-Up Networking

This section describes the steps to create and configure a dial-up connection in Windows 2000. See Windows NT Dial-Up Networking in this appendix for Windows NT instructions page 97, and Windows 95/98 Dial-Up Networking in this appendix for Windows 95/98 instructions page 91.

Create a Dial-Up Connection in Windows 2000

To create a phonebook entry in Windows 2000, complete the following steps:

1. Double-click the My Computer icon on the desktop and then double-click the Control Panel folder and then double-click the Network and Dial-Up Connections folder.

2. Double-click Make New Connection

   The Network Connection Wizard appears.

3. Click Next.

   The Network Connection Type window appears.

   ![Network Connection Wizard]

   - **Dial-up to private network**
     Connect using telephone line (modem or ISDN).
   - **Dial-up to the Internet**
     Connect to the Internet using a phone line (modem or ISDN).
   - **Connect to a private network through the Internet**
     Create a Virtual Private Network (VPN) connection or tunnel through the Internet.
   - **Accept incoming connections**
     Let other computers connect to mine by phone line, the Internet, or direct cable.
   - **Connect directly to another computer**
     Connect using my serial, parallel, or infrared port.

   Next >
4. Select **Dial-up to private network**.
   The Phone Number to Dial window appears:
   
   ![Phone Number to Dial window](image)
   
   5. Enter “1” as the phone number and then click **Next**.
   The Connection Availability window appears.
   
   6. Select **For All Users** and then click **Next**.
   The Completing the Network Connection window appears.
   
   ![Completing the Network Connection window](image)
   
   7. Enter a name for the new phonebook entry and then click **Finish**.
   **Important** The name must be “MachineShop Phonebook Entry” if you are using the Direct Connection (Serial) option in MachineShop.
Appendix A: MachineShop Dial-Up Networking Connections

Configure the Connection in Windows 2000

Now you need to configure the phonebook entry.

To configure the phonebook entry, complete the following steps:

1. Double-click the My Computer icon on the desktop and then double-click the Control Panel folder and then double-click the Network and Dial-Up Connections folder.

   The Network and Dial-Up Connections window appears.

2. Right click on the icon for the newly created connection and then select Properties.

3. The property sheet for the selected connection appears.
4. Select Configure.  
The Modem Configuration dialog box appears.

5. Select the Maximum speed (bps) that the modem will use to transfer data.  
The default is 115200. This selection must match the baud rate set in the MachineShop Shell.  
   Note If you have reliability problems using the selected speed, try selecting a slower speed.  
6. Click OK.
7. Click the **Networking** tab.

The Networking tab appear.

8. Clear all check boxes except the **Internet Protocol (TCP/IP)** check box and the **Client for Microsoft Networks** check box. Click on the Internet Protocol line, then click **Properties** to configure the IP address.

The TCP/IP Properties window appears.
9. Select **Use the following IP address** and then enter the IP address for the development system.
   
   CTC recommends that you enter 10.0.0.1 as the IP address for the development system.

   **Note**  
   If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

10. Leave the **Use the following DNS server addresses** blank.

11. Click **OK** to accept these choices.
   
   The Edit Phonebook Entry property sheet appears.

12. Click **OK** to exit the Edit Phonebook Entry property sheet.
Cable Pinouts

This appendix describes the cable pinouts for a LAN cable, crossover cable, serial cable with hand-shaking, and a serial null modem cable with loopback. If you should decide to construct your own cable, refer the appropriate diagram below for assistance.

10 Base-T, 100 Base-T Ethernet LAN Cable Pinout

<table>
<thead>
<tr>
<th>1</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orange-white</td>
<td>Green-white</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>Orange</td>
<td>Green</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Green-white</td>
<td>Orange-white</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Blue</td>
<td>Blue</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Blue-white</td>
<td>Blue-white</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>Green</td>
<td>Orange</td>
</tr>
<tr>
<td>7</td>
<td>7</td>
</tr>
<tr>
<td>Brown-white</td>
<td>Brown-white</td>
</tr>
<tr>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>Brown</td>
<td>Brown</td>
</tr>
</tbody>
</table>

RJ-45 Connector
10 Base-T, 100 Base-T Ethernet Peer to Peer Crossover Cable Pinout

10 Base-T/100 Base-T Ethernet Peer to Peer Crossover Cable

<table>
<thead>
<tr>
<th>Orange-white</th>
<th>1</th>
<th>1</th>
<th>Green-white</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orange</td>
<td>2</td>
<td>2</td>
<td>Green</td>
</tr>
<tr>
<td>Green-white</td>
<td>3</td>
<td>3</td>
<td>Orange-white</td>
</tr>
<tr>
<td>Blue</td>
<td>4</td>
<td>4</td>
<td>Blue</td>
</tr>
<tr>
<td>Blue-white</td>
<td>5</td>
<td>5</td>
<td>Blue-white</td>
</tr>
<tr>
<td>Green</td>
<td>6</td>
<td>6</td>
<td>Orange</td>
</tr>
<tr>
<td>Brown-white</td>
<td>7</td>
<td>7</td>
<td>Brown-white</td>
</tr>
<tr>
<td>Brown</td>
<td>8</td>
<td>8</td>
<td>Brown</td>
</tr>
</tbody>
</table>

RJ-45 Connector
## MachineShop Serial PPP Cable with Hardware Handshaking Pinout

### Serial Cable with Hardware Handshake

<table>
<thead>
<tr>
<th>9-pin</th>
<th>25-pin</th>
<th>25-pin</th>
<th>9-pin</th>
<th>Pin Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>7</td>
<td>7</td>
<td>5</td>
<td>Gnd ←→ Gnd</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>3</td>
<td>2</td>
<td>Xmit ←→ Rcv</td>
</tr>
<tr>
<td>7</td>
<td>4</td>
<td>5</td>
<td>8</td>
<td>RTS ←→ CTS</td>
</tr>
<tr>
<td>6\1</td>
<td>6\8</td>
<td>20</td>
<td>4\</td>
<td>DSR, CD ←→ DTR</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>2</td>
<td>3</td>
<td>Xmit ←→ Rcv</td>
</tr>
<tr>
<td>8</td>
<td>5\2</td>
<td>4\3</td>
<td>7</td>
<td>CTS ←→ RTS</td>
</tr>
<tr>
<td>4\2\8</td>
<td>6\8\1</td>
<td>6\1</td>
<td></td>
<td>DTR ←→ DSR, CD</td>
</tr>
</tbody>
</table>

**9-pin connector**

- 5\(\cdots\)1
- 9\(\cdots\)/6

**25-pin connector**

- 13\(\cdots\)/1
- 25\(\cdots\)/14

---

*MachineShop Getting Started Guide*  
111
MachineShop Serial PPP Null Modem Cable with Loopback Pinout

Serial Null Modem Cable with Loopback

<table>
<thead>
<tr>
<th>9-pin</th>
<th>25-pin</th>
<th>25-pin</th>
<th>9-pin</th>
<th>Pin Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>7</td>
<td>7</td>
<td>5</td>
<td>Gnd ← → Gnd</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>3</td>
<td>2</td>
<td>Xmit ← → Rcv</td>
</tr>
<tr>
<td>7</td>
<td>4</td>
<td>5</td>
<td>8</td>
<td>RTS ← → CTS</td>
</tr>
<tr>
<td>6 1</td>
<td>6 8</td>
<td>20</td>
<td>4</td>
<td>DSR, CD ← → DTR</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>2</td>
<td>3</td>
<td>Xmit ← → Rcv</td>
</tr>
<tr>
<td>8</td>
<td>5</td>
<td>4</td>
<td>7</td>
<td>CTS ← → RTS</td>
</tr>
<tr>
<td>4</td>
<td>20</td>
<td>6 8</td>
<td>6 1</td>
<td>DTR ← → DSR, CD</td>
</tr>
</tbody>
</table>

9-pin connector: 5(00000); 9(0000/6)
25-pin connector: 13(0000000000000000); 14(00000000000000000000000000000)
Index

A

add
creation
direct serial 40
disk transfer 63
Ethernet point to point 45
IPM compatible 61
LAN 42
modem 58
serial 55
suite component 88
Always on Top 86
AutoHide 86

B

backup 66
local 66
remote 68
restore 69
baud rate 41, 94, 100
modify 93, 99, 104

cable pinouts 109
configure
dial-up connection
   Windows 2000 51, 104
   Windows 95/98 93
   Windows NT 99
TCP/IP properties
   Windows 2000 51
   Windows 95/98 46
   Windows NT 48
connection
   Ethernet point to point 45
   IPM compatible 61
LAN 42
modem 58
serial 55
create
backup
   local project backup 66
   remote project backup 68
dial-up connection
   Windows 2000 102
   Windows 95/98 91
   Windows NT 97
project 24
Crossover Cable Pinout 110
Customer Support Services 4
customizing MachineShop 85
   add suite component 88
   remove suite component 90
   visibility 86
customizing MachineShop edit suite component 89

D
delete a project 30
development system requirements 9
Dial-Up Networking 58, 59, 91
   add connection
      Windows 2000 102
      Windows 95/98 91
      Windows NT 97
   configure connection
      Windows 2000 104
      Windows 95/98 93
      Windows NT 99
   modify
      baud rate 93, 99, 104
      TCP/IP settings 93, 99, 104
Direct Serial communication 40
Direct Serial connection 40
docking the toolbar 87
documentation
Index

standards 3
download project 76
download command 78
transfer wizard 76

E
edit I/O interface 36
Edit menu 18
edit project description 33
edit suite component 89
Ethernet point to point connection 45
TCP/IP Properties
configure in Windows 2000 51
TCP/IP Properties in Windows 95/98 45
TCP/IP Properties in Windows NT 48

F
File menu 18

H
hardware requirements
development system 9
runtime system 10
Help menu 19
Host Name 44

I
IP Address 44, 47, 50, 52, 60
IPM 15
IPM Compatible Serial connection 61

L
LAN Cable Pinout 109
LAN connection 42
launch
Interact 20, 29
MachineLogic 20, 29

M
MachineLogic templates 24
MachineShop
add suite component 88
features 8
remove suite component 90
start 16
visibility 86
MachineShop Direct Connection modem 92
MachineShop edit suite component 89
MachineShop Net 18
MachineShop Net connection
Ethernet point to point 45
LAN 42
modem 58
serial 55
MachineShop Net Name 44
MachineShop Phonebook Entry 55, 56, 92
create 91
Menus 18
Edit menu 18
File menu 18
Help menu 19
Tools menu 18
Transfer menu 19
View menu 18
Window menu 19
modem connection 58

O
Online Help 16
open a project 29
Options command 86

P
Product Support Program 6
project
Index

backup 66
create 24
delete 30
description 33
directory structure 22
download 76
I/O interface 36
information 31
open 29
overview 22
project path 23
restore 69
save 30
upload 80
Project Management Rebar 19

R
rebars 19
move 87
project management 19
suite navigation 20
transfer 20
remove suite component 90
restore 69
local project 69
remote project 71
runtime system requirements 10

S
save a project 30
security key 11
Security Key Utility 12
enable software options 13
transfer options between keys 14
Serial Cable with Hardware Handshaking
Pinout 111
serial connection 55
Serial Null Modem Cable with Loopback
Pinout 112
setting project path 23
software requirements
development system 9
runtime system 11
starting MachineShop 16
startup files 23, 32
Suite Navigation Rebar 20

T
TCP/IP 41
TCP/IP properties
configure in Windows 2000 51
configure in Windows 95/98 46
configure in Windows NT 48
TCP/IP settings 50, 96, 101, 106
modify 93, 99, 104
Technical Support 4
Toolbar
always on top 86
dock 87
hide 86
move 87
moving 17
undock 87
visibility 86
Toolbars 19
Tools menu 18
Training and New Business Development 5
Transfer menu 19
Transfer Rebar 20

U
undocking the toolbar 87
upload project 80
transfer wizard 80
upload command 82
user interface 17
user-defined toolbar buttons
## Index

<table>
<thead>
<tr>
<th>V</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>View menu 18</td>
<td></td>
</tr>
<tr>
<td>view project information 31</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>W</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome dialog 17</td>
<td></td>
</tr>
<tr>
<td>What’s This Help 16</td>
<td></td>
</tr>
<tr>
<td>Window menu 19</td>
<td></td>
</tr>
</tbody>
</table>