MACHINESHOP

Getting Started Guide
Copyright and Trademark Notice

Copyright © 2000 by CTC Parker Automation. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, in any form or by any means, mechanical, photocopying, recording or otherwise, without the prior written consent of CTC Parker Automation.

While every precaution has been taken in the preparation of this manual, CTC Parker Automation and the author assume no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of the information contained herein. All product and company names are trademarks of their respective companies and licenses.

Product Warranty Information

CTC Parker Automation provides top quality products through rigid testing and the highest quality control standards. However, should a problem occur with your hardware or with the software protection key, CTC’s standard product warranty covers these items for 15 months from the date of shipment from CTC. Exceptions appear below:

- PowerStation backlight bulbs have a 90-day warranty.
- Third-party products, such as bus cards, carry the manufacturer’s specified warranty.
- For all displays, image retention (burn-in) is not covered by warranty.
- Software revisions that occur within 60 days after purchase are available under warranty upon request. Please review the Interact License Agreement for additional software warranty information.

Should you have any questions about your application or need technical assistance, please call CTC’s Product Technical Support department at 513-248-1714, 8:00am to 5:00pm, EST. You may call this same number after hours for emergency assistance. See Customer Support Services on page 7 of this manual for more information about CTC’s support products and services.
# Table of Contents

## Chapter 1 Manual Overview and Support Services ............ 1

- Using this Manual .......................................................... 2
- MachineShop Documentation .............................................. 3
  - Print Documentation ...................................................... 3
  - Electronic Documentation .............................................. 4
- Related Documentation ..................................................... 5
- Documentation Standards ................................................ 6
  - ISO Symbols .............................................................. 6
- Customer Support Services ................................................. 7
  - Technical Support ........................................................... 7
  - Training and New Business Development ............................ 8
  - Product Support Program ................................................ 8
- Chapter Summary .......................................................... 8

## Chapter 2 Introducing MachineShop ......................... 9

- MachineShop Basics ....................................................... 10
- Development System Requirements ..................................... 11
  - Hardware Requirements .................................................. 11
  - Software Requirements .................................................. 11
  - Installing the Software .................................................. 12
- Runtime System Requirements ............................................ 12
  - Hardware Requirements .................................................. 12
  - Installing the Hardware .................................................. 12
  - Software Requirements .................................................. 13
  - Installing the Software .................................................. 13
- Working with Security Keys ............................................. 13
  - Understanding the Security Keys ..................................... 13
  - Using the Security Key Utility ........................................ 14
Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabling Software Options</td>
<td>15</td>
</tr>
<tr>
<td>Transferring Enabled Options between Keys</td>
<td>16</td>
</tr>
<tr>
<td>Getting Started with MachineShop</td>
<td>17</td>
</tr>
<tr>
<td>Users of Interact Project Manager (IPM)</td>
<td>17</td>
</tr>
<tr>
<td>Online Help</td>
<td>18</td>
</tr>
<tr>
<td>Starting MachineShop</td>
<td>18</td>
</tr>
<tr>
<td>MachineShop User Interface</td>
<td>20</td>
</tr>
<tr>
<td>Menus</td>
<td>20</td>
</tr>
<tr>
<td>File Menu</td>
<td>20</td>
</tr>
<tr>
<td>Edit Menu</td>
<td>20</td>
</tr>
<tr>
<td>View Menu</td>
<td>20</td>
</tr>
<tr>
<td>Tools Menu</td>
<td>21</td>
</tr>
<tr>
<td>Transfer Menu</td>
<td>21</td>
</tr>
<tr>
<td>Window Menu</td>
<td>21</td>
</tr>
<tr>
<td>Help Menu</td>
<td>21</td>
</tr>
<tr>
<td>Toolbars</td>
<td>22</td>
</tr>
<tr>
<td>Project Management Rebar</td>
<td>22</td>
</tr>
<tr>
<td>Suite Navigation Rebar</td>
<td>22</td>
</tr>
<tr>
<td>Transfer Rebar</td>
<td>23</td>
</tr>
<tr>
<td>Chapter Summary</td>
<td>23</td>
</tr>
<tr>
<td><strong>Chapter 3 Managing Projects</strong></td>
<td>25</td>
</tr>
<tr>
<td>Overview of MachineShop Projects</td>
<td>26</td>
</tr>
<tr>
<td>Project Directory Structure</td>
<td>26</td>
</tr>
<tr>
<td>Startup Files</td>
<td>27</td>
</tr>
<tr>
<td>Setting the Project Path</td>
<td>27</td>
</tr>
<tr>
<td>Create a New Project</td>
<td>28</td>
</tr>
<tr>
<td>Open an Existing Project</td>
<td>32</td>
</tr>
</tbody>
</table>
## Table of Contents

- Save a Project .......................................................... 33
- Delete a Project ......................................................... 34
- View Project Information ............................................. 35
- Edit a Project ............................................................ 36
  - Project Description .................................................. 36
  - I/O Interface .......................................................... 37
  - Memory and Ports .................................................... 37
- Chapter Summary .......................................................... 38

### Chapter 4  Adding Connections ................................. 39

- MachineShop Net Connections .................................... 40
  - LAN Connection ..................................................... 40
  - Ethernet Point to Point Connection ............................ 43
    - Configure TCP/IP Properties in Windows 95/98 ............ 43
    - Configure TCP/IP Properties in Windows NT ............... 46
    - Add Connection in MachineShop ............................... 49
  - Serial Connection ................................................. 52
  - Modem Connection .................................................. 55
- IPM Compatible Connection ......................................... 58
- Disk Transfer Connection ............................................ 60
- Chapter Summary .......................................................... 61

### Chapter 5  Backing Up Projects ............................... 63

- Creating a Backup .................................................... 64
  - Local Project Backup .............................................. 64
  - Remote Project Backup ............................................ 66
- Restoring a Backup .................................................... 67
  - Restore Backup to the Local System ............................ 67
  - Restore Project to a Remote System ............................ 70
Table of Contents

Chapter Summary ......................................................... 72

Chapter 6  Transferring Projects ................................. 73
  Downloading a Project ............................................... 74
    Transfer Wizard ..................................................... 74
    Download Command .................................................. 76
  Uploading a Project ................................................ 78
    Transfer Wizard ..................................................... 78
    Upload Command ................................................... 80

Chapter Summary ..................................................... 81

Chapter 7  Customizing MachineShop ......................... 83
  Set the Visibility ................................................... 84
  Move the MachineShop Toolbars ................................ 85
    Move the MachineShop Rebars .................................. 85
  Add, Edit, and Remove Suite Components ...................... 86
    Add a Program ..................................................... 86
    Edit a Program ................................................... 87
    Remove a Program ................................................ 88

Chapter Summary ..................................................... 88

Appendix A  MachineShop Dial-Up Networking Connections . 89
  95/98 Dial-Up Networking ........................................... 89
    Create a Dial-Up Connection ..................................... 89
    Configure the Connection ......................................... 91
  Windows NT Dial-Up Networking ................................ 95
    Create a Dial-Up Connection ..................................... 95
    Configure the Connection ......................................... 97

Appendix B  Cable Pinouts ............................................ 101
  10BaseT, 100BaseT LAN Cable Pinout ............................ 101
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10BaseT, 100BaseT Peer to Peer Crossover Cable Pinout</td>
<td>102</td>
</tr>
<tr>
<td>Serial Cable with Hardware Handshaking Pinout</td>
<td>103</td>
</tr>
<tr>
<td>Serial Null Modem Cable with Loopback Pinout</td>
<td>104</td>
</tr>
<tr>
<td>Index</td>
<td>105</td>
</tr>
</tbody>
</table>
Welcome to MachineShop. MachineShop is an application that provides a simple, intuitive graphical interface for the management of a machine profile or project. MachineShop pulls together the suite of machine control applications used to define a project, including Interact and MachineLogic, into a common toolbar interface that allows easy desktop access to the major functions of the software. MachineShop also includes multiple task wizards to make the management and creation of projects easier.
This manual describes the MachineShop user interface and provides instructions on how to create and manage projects which use Interact applications and/or MachineLogic projects. You should read and understand the concepts presented in this manual prior to operating MachineShop. This manual is divided into the following chapters:

Chapter 1 - Manual Overview and Support Services: Presents an overview of the documentation that is provided with MachineShop. This chapter also provides an overview of the support services provided by CTC.

Chapter 2 - Introducing MachineShop: Describes the hardware and software requirements for MachineShop. Also describes how to navigate the MachineShop Toolbar, how to get help, and introduces you to the user interface.

Chapter 3 - Managing Projects: Provides descriptive and instructional information on using MachineShop to manage your projects. This includes creating a project, opening an existing project, and viewing project information.

Chapter 4 - Adding Connections: Describes how to set up the development system for file transfers. This includes adding MachineShop Net, IPM Compatible Serial, and disk transfer connections. MachineShop Net connections include a LAN, serial, Ethernet point to point and modem connection.

Chapter 5 - Backing Up Projects: Describes how to backup and restore projects using the Backup and Restore Wizards. This includes backing up and restoring local and remote projects.

Chapter 6 - Transferring Projects: Describes how to transfer project files to and from the runtime system using the connections created in Chapter 3.

Chapter 7 - Customizing MachineShop: Describes how to customize some of the basic MachineShop operations including adding and removing frequently used programs to the MachineShop Toolbar.

Appendix A - MachineShop Dial-Up Networking Connections: Describes how to create and configure MachineShop Dial-Up Networking connections in Windows 95/98 and Windows NT.

Appendix B - Cable Pinouts: Describes the cable pinouts for a LAN cable, crossover cable, serial null modem cable with loopback, and serial cable with hardware handshaking.
MachineShop Documentation

The MachineShop package includes all of the documentation you need to install, configure, and run MachineShop. In addition, the package includes all the necessary information to develop Interact applications and MachineLogic projects. Extensive online help exists for MachineShop, Interact, and MachineLogic as well. Please review the following list to verify that you have received all necessary documentation.

Print Documentation

MachineShop is shipped with the following print documentation:

License Agreement - The License Agreement explains the terms of the MachineShop component and serves as a certificate of authenticity. This document also lists the product warranty information provided by CTC. Make sure you read and understand the information in this agreement before you install and operate MachineShop.

Customer Support Information - The Customer Support document describes how to contact CTC with your comments, questions, and concerns regarding the MachineShop product.


Interact Getting Started Guide - The Interact Getting Started Guide is designed to help you get up and running with Interact. This manual describes Interact concepts, and includes example applications detailing the features of most Interact modules.

MachineLogic Getting Started Guide - The MachineLogic Getting Started Guide is designed to help you get up and running with MachineLogic. This manual describes the user interface and provides instructions on how to create and online monitor MachineLogic projects.
In addition to the MachineShop print documentation, the following electronic documentation is available:

**MachineLogic Tutorial** - The MachineLogic Tutorial provides step-by-step instructions for using the MachineLogic Tutorial Template to create, download, and run a MachineLogic project. The tutorial is a Portable Document Format (PDF) document and is accessible from the MachineShop program group.

**MachineLogic Reference** - The MachineLogic Reference is a comprehensive guide to using MachineLogic. This guide provides detailed instructions on how to create, edit, and compile MachineLogic projects. It also describes some IEC 1131 basics. This manual is a Portable Document Format (PDF) document and is accessible from the MachineShop program group.

**MachineLogic Runtime Reference** - The MachineLogic Runtime Reference provides information on the MachineLogic Runtime kernel. It contains basic concepts and system specifics on the MachineLogic Runtime to help you structure your MachineLogic project. This manual is a Portable Document Format (PDF) document and is accessible from the MachineShop program group.

**Online Help Files** - Extensive online help is accessible from MachineShop, Interact, and MachineLogic. The online help contains detailed information on the products and describes how to perform all product operations. To access the online help available for a specific part of the program, press the F1 key on your keyboard.

**I/O Driver Online Help** - The I/O Driver online help is accessible from the MachineShop Toolbar and the MachineShop program group. The online help provides a technical overview of the I/O driver and contains detailed instructions on how to configure the I/O driver for MachineLogic.

**Interact Tutorial** - The Interact Tutorial is an online help file that is designed to be run on the Interact development system. This help file includes step-by-step instructions for creating applications using the Panel Toolkit Module (PTM), the Graphics Monitoring Module (GMM), and the Alarm Management Module (AMM), which will help you become familiar with Interact. The Interact Tutorial is accessible from the MachineShop program group.
Related Documentation

In addition to the documentation that is included in the MachineShop package, you should become familiar with the following documentation:

**I/O Interface Card Documentation** - This documentation is supplied by the manufacturer of your I/O interface card. Please read this documentation in its entirety prior to downloading or running an Interact application or MachineLogic project.

**PowerStation User Guide** - If you are running MachineLogic or Interact on a CTC PowerStation, you should have received this manual. This manual explains how to configure, install, and operate the PowerStation. Please familiarize yourself with this manual prior to operating the unit.

**MachineShop Shell Runtime User Guide** - This manual provides instructions on how to use the MachineShop Shell to monitor and configure a PowerStation or any non-CTC workstation communicating with a development system running MachineShop. This includes creating and restoring backups and preparing the workstation for transfers. Please read this manual prior to downloading an Interact application or MachineLogic project from the MachineShop toolbar.

**Windows Documentation** - This manual assumes you have a thorough knowledge of the Windows operating system when working with MachineShop. If this is not the case, then refer to the documentation shipped with your operating system for details on Windows.
Documentation Standards

As you read this manual, you will notice that the following documentation standards have been followed.

1. Important terms are shown in **bold**.

2. Text to be entered from the keyboard is shown in **Courier font**.

3. Buttons, menu titles, and keyboard keys are shown in Initial Caps.

4. Indented paragraphs denote one of the following:
   - **Note** - Describes alternative approaches or issues you should be aware of while using a particular function.
   - **Important** - Contains information that needs particular attention while reading the text. Follow this information to save development time and/or minimize problems.
   - **Warning** - Contains information on safety issues. Follow this information to prevent equipment damage or personal injury.

ISO Symbols

This symbol is the International Standards Organization (ISO) symbol for Caution (ISO 3864 No. B.3.1). This symbol denotes information that could affect operation of the PowerStation if not properly followed.

This symbol is the ISO symbol for Caution - risk of electrical shock (ISO 3864 No B.3.6). This symbol denotes information that could cause personal injury from electrical shock or damage to equipment if not properly followed.
Customer Support Services

We welcome your thoughts and suggestions on our products and services. You can contact us by telephone, email, or fax. You can also visit CTC Parker on the World Wide Web to learn the latest about our hardware, software, and customer support services.

- Telephone: 513-831-2340
- Fax: 513-831-5042
- E-mail: sales@ctcusa.com or support@ctcusa.com
- World Wide Web: http://www.ctcusa.com

We recognize that every customer and every application has different support needs, so we offer a variety of support services designed to meet these needs. We offer three types of customer support services: Technical Support, Training and New Business Development, and the Product Support Program.

Technical Support

The Technical Support department welcomes any question that might arise as you develop or run your applications. We offer complimentary support for any customer, whether you are an end user, original equipment manufacturer (OEM), or system integrator, or distributor.

If you have a question about MachineShop, Interact, or MachineLogic, be sure to complete the following steps:

1. Check the Readme files installed with the software. These files provide general information about the release.
2. Consult the appropriate documentation and other printed materials included with MachineShop, Interact, and MachineLogic.
3. Check the online help. MachineShop, Interact, and MachineLogic each have extensive online help facilities that cover all aspects of the product.

If you cannot find a solution using one of the above sources, contact our Technical Support department at 513-248-1714, 8:00 a.m. to 5:00 p.m., Eastern Time. You can call this same number after hours for emergency assistance.
Training and New Business Development

Our Training and New Business Development department provides service in two areas: training and consulting. We offer training on all our products, either at CTC Parker in our state-of-the-art training center or at your site. You can learn how to write custom interfaces, develop specialized applications, and implement your complete machine control application. Contact the Training Coordinator by phone at 1-800-233-3329 or by email at training@ctcusa.com.

We offer consulting services through our Professional Consulting Services (PCS) group. Our PCS group can build your application from the ground up by writing custom communications drivers or designing special modules to perform functions unique to your application. Our team of specialists is flexible, so they can create a project development schedule that meets your needs. Contact the PCS Coordinator by phone at 1-800-233-3329 or by email at pcs@ctcusa.com.

Product Support Program

The Product Support Program (PSP) is designed to keep you up-to-date with the current version of CTC Parker software. The PSP consists of a renewable, one-year membership that provides you with free upgrades, utilities, automatic notification of software updates, and other valuable tools for MachineShop. Single-user, site, and corporate licenses are available. The PSP is an easy, cost-effective way to automatically receive the most recent CTC Parker software and the associated utilities. Contact the PSP Coordinator by phone at 1-800-233-3329 or by email at psp@ctcusa.com.

Chapter Summary

This chapter has provided a general overview of the documentation that is provided with MachineShop as well as the supporting documentation that you may find useful as you develop MachineShop projects. This chapter has also provided an overview of CTC’s support products and services.

In the next chapter you will learn about the MachineShop user interface as well as the system requirements for running MachineShop.
Chapter 2

Introducing MachineShop

MachineShop is a suite of software products designed for machine control. The Suite includes three machine control programs: Interact, MachineLogic, and the MachineShop Toolbar. The MachineShop Toolbar provides a simple user interface for managing a machine profile or project. The machine control programs that are managed by the MachineShop Toolbar are modular and may be used independently of one another.

This chapter describes the features of MachineShop and introduces you to the MachineShop Toolbar. It also describes the system requirements for the MachineShop development and runtime systems.

Chapter Contents

- MachineShop Basics 10
- Development System Requirements 11
- Runtime System Requirements 12
- Working with Security Keys 13
- Getting Started with MachineShop 17
- MachineShop User Interface 20
- Chapter Summary 23
MachineShop Basics

MachineShop has a simple, easy-to-use interface for configuring and managing machine profiles or projects. Through the use of wizards for multi-step procedures and explorer-type windows for file management, MachineShop has simplified and automated the most common tasks associated with machine projects.

MachineShop provides the necessary functionality to develop projects, including creating new projects, opening or backing up existing projects, launching various Suite programs, and transferring projects and files to and from runtime workstations such as PowerStations.

The purpose of MachineShop is to perform the following operations:

- Provide a central location for managing the development and runtime files for Interact and MachineLogic, whether used together or separately
- Provide a simple user interface for transferring projects and their components to target runtime workstations such as PowerStations
- Provide a simple user interface for backing up and restoring projects to/from runtime workstations or a variety of storage devices (diskette, Compact Flash, hard drive, network, etc.)
- Provide a variety of communication options for transferring projects and performing backups, including serial, LAN, and disk connections

The next section of this chapter will list the hardware and software requirements to run MachineShop. The remaining sections of the chapter will discuss working with security keys and getting started with MachineShop, including how to get help.
Development System Requirements

The development system is the computer you plan to use to create and manage your MachineShop projects. This computer will not be used to run the projects that you create. Instead, you will use this computer to manage and transfer your projects to and from a workstation which will be used to run your projects.

A workstation that runs MachineShop projects is referred to as a runtime system throughout this manual. A standard industrial PC may be used as a runtime system. This manual assumes you are using a CTC PowerStation as your runtime system.

Hardware Requirements

Your development system must meet or exceed the following system requirements in order for MachineShop to perform as intended:

- Processor: Pentium 133MHz
- Memory: 24MB RAM (Windows 95/98 systems)
- Memory: 32MB RAM (Windows NT systems)
- Fixed Storage: 50MB of free hard disk space
- Removable Storage: CD-ROM drive
- Input Devices: keyboard and Microsoft compatible mouse
- Video: 800 x 600 resolution, 256 colors
- 10 MB Ethernet network interface or serial port

Software Requirements

Your MachineShop development PC requires the following software in order to develop MachineShop projects:

- Operating System: Windows 95 4.00.950B (OSR2), Windows 98, Windows 2000, or Windows NT 4.0 SP3
  
  **Note** DCOM 95 must be installed if using Windows 95/98. A self-extracting executable install is provided on the MachineShop install CD in the DCOM 95 directory. This directory is automatically installed once you install MachineShop.

- Interact: Version 5.0 or later

  **Note** Interact Version 6.0 is required if you are using Interact with MachineLogic.

- MachineLogic: Version 2.0 or later
Installing the Software


Runtime System Requirements

The runtime system is the PowerStation or industrial PC you plan to use to run your MachineShop projects. This computer will only be used to run the projects you create. You will develop your projects on a development system and download them to this computer.

The workstation used as a runtime system requires the MachineShop Shell. The “Shell” is an easy-to-use interface that communicates with the MachineShop development machine. For more information on the MachineShop Shell, see the *MachineShop Shell Runtime User Guide*.

Hardware Requirements

Your runtime system must meet or exceed the following MachineShop system requirements in order for MachineShop projects to perform as intended:

- Processor: 80386-SX 25MHz or higher
- Memory: 4MB
- Fixed Storage: 8MB
- Video: 320 x 240 or 640 x 480 resolution, 16 colors
- Input Device: Microsoft compatible mouse or equivalent
- Third Party I/O Card
- MachineLogic Control Adapter, if using MachineLogic
- 10MB Ethernet network interface card or serial port

**Important** The MachineLogic Control Adapter must be installed before you can use projects that include MachineLogic components.

Installing the Hardware

In order to run MachineLogic projects on your runtime system, you must install the MachineLogic Control Adapter and the appropriate I/O card in the runtime system. Refer to the *MachineLogic Control Adapter Installation* document and the document that came with your I/O card for step-by-step instructions on how to install both the control adapter card and I/O card.
Chapter 2: Introducing MachineShop

Working with Security Keys

Software Requirements

Your runtime PC requires the following software in order to run MachineShop projects:

- Operating Systems: MS-DOS 6.22 or later
- Interact Runtime: Version 5.0 or later

**Note** Interact Version 6 is required if you are using Interact with MachineLogic

- MachineLogic Runtime: Version 1.11 or later
- MachineShop Shell: Version 1.0 or later

Installing the Software

Refer to the *MachineShop Installation Booklet* for step-by-step instructions on how to install and setup the MachineShop software components.

Working with Security Keys

The MachineLogic and Interact software that is installed using the MachineShop CD is run with a security key. This section describes options for viewing and enabling key options.

**Note** The MachineShop Toolbar is not key protected and may be used on any appropriate system to transfer projects, create runtime system backups, or restore runtime backups.

Understanding the Security Keys

Included with the MachineShop CD is a security key. The security key has a label on it which indicates the key type, key number, and the serial number as shown below:

![Security Key Image]

MachineShop Getting Started Guide 13
Every security key has a unique 15-digit serial number. This serial number is used to provide assurance that unauthorized users cannot use your copy of the Interact and MachineLogic software without violating the License Agreement. Since your key has a unique serial number, we can provide this protection by enabling only the software options you have purchased.

The key is designed to plug directly into the parallel (printer) port of your computer. A printer cable can be plugged into the other end of the key. Your printer will work normally as the presence of the key does not affect its operation.

**Using the Security Key Utility**

The Security Key Utility allows you to program your Security Key. You can enable additional software options or transfer enabled software options between keys.

A sample of the Security Key Utility screen is shown below.

![Security Key Utility Screen](image)

This screen displays a check mark next to the options that are enabled within your key. A single check mark in the Runtime column means that option is enabled for runtime operation only. Check marks in the Configuration and Runtime columns indicate that the option is enabled for application development and runtime.
For most users, the options you purchased are enabled at the factory prior to shipping you the product. You should have check marks shown for each option you ordered. If you do not have check marks next to the options you purchased, then you must enter the 8-digit “enable codes” printed on the Module Enable Code Certificate.

**Enabling Software Options**

When you order additional software components, you will receive a Module Enable Code Certificate listing enable codes for each software option purchased. These enable codes are used to activate the respective software options on the security key. The codes are generated for the key number and serial number printed on your key and are valid ONLY for that key.

**To enable software options, follow these steps:**

1. Install the software on your system following the procedure described in the *MachineShop Installation Booklet*.

2. Make sure your key is attached to the parallel port of your computer.

3. Click **Start** on the Taskbar.
   
   The Start menu opens.

4. Select **MachineShop** from the Programs folder.
   
   The MachineShop folder opens.

5. Click the **Security Key Utility** icon.
   
   The Key Setup Main Menu is displayed.

6. Select the **Enable Option** command.

7. Enter an enable code to activate a software option.

8. Repeat steps 4 and 5 for each enable code.
   
   As enable codes are entered, you will see a check mark appear on the display to the right of the software option that is enabled. If the enable code was for activating development, two check marks will appear, one in the Configuration column and one in the Runtime column.

9. Return to the **Security Key Main Menu**.
10. Exit the **Security Key Utility** by selecting the **Exit Menu** option. 

You are returned to the Windows desktop.

**Transferring Enabled Options between Keys**

Enabled software options may be transferred from one key to another. You must have two keys in order to transfer enabled options, and both keys must be attached to the computer at the same time. You can plug each key into a separate parallel port, or you can cascade the two keys together and plug them into a single parallel port.

The Security Key Utility identifies one key as the source and the other as the destination. Enabled software options can only be transferred from the source key to the destination key. Enabled options that were originally activated with an enable code and subsequently transferred can be re-enabled only by transferring them back from another key.

**To transfer options between keys, follow these steps:**

1. Attach two keys to your computer (each in a parallel port, or cascaded).
2. Click **Start** on the Taskbar. 
   The Start menu opens.
3. Select **MachineShop** from the Programs folder.
   The MachineShop folder opens.
4. Click the **Security Key Utility** icon.
   The Key Setup Main Menu is displayed.
5. Select the **Transfer Option** command from the Main Menu.
   The Key Setup Utility automatically detects the two keys and displays the options enabled in each one.
6. Select the **Select Keys** command from the **Transfer Options** menu to identify which key is the source and which is the destination.
7. Click on the **Select Keys** command to alternate source and destination, if necessary.
8. Choose the **Select Option** command from the **Transfer Options** menu.
9. Select the option you want to transfer from the list of enabled options in the source key. If necessary, specify whether to transfer Configuration Only, Runtime Only, or Development (both).

10. Select Yes to transfer the selected option.

11. Exit the Security Key Utility by selecting the Exit Menu. You are returned to the Windows desktop.

Getting Started with MachineShop

Before you begin creating and managing projects in MachineShop, there are a few important notices you should review.

Users of Interact Project Manager (IPM)

MachineShop was designed to replace Interact Project Manager (IPM); however, MachineShop is capable of reading projects that were created in IPM, Interact, or MachineLogic.

Note In order for MachineShop to read these projects, they must be located in the MachineShop Projects directory on your hard drive. See Chapter 3 for information about the Project Directory structure.

In fact, MachineShop will prompt you whenever you attempt to open a project and it detects Interact or MachineLogic application files on your system that are not part of a MachineShop project. MachineShop displays the following message:
Once the MachineShop files exist, you can use MachineShop to view and download all your projects to the PowerStation Shell that you ordinarily download using IPM.

**Important** Creating MachineShop files does not prevent you from continuing to use IPM to download Interact projects to the PowerStation Shell; however, you cannot use IPM to download Interact projects to the MachineShop Shell.

MachineShop is also capable of reading project backups that were created with IPM. When you restore a project backup that was created with IPM, MachineShop maintains the directory structure for Interact projects.

**Online Help** Online Help is available if you have any questions about how to perform a particular operation or need information about the elements appearing on the screen. To access the online help simply select Help from the MachineShop Toolbar.

There are several ways to find help in the MachineShop help file. You may view the help contents, perform an index search, or search for specific words or phrases using the Find tab in the help window.

MachineShop also provides What’s This Help. What’s This Help shows information about different elements on the screen. To use the What’s This Help for a dialog box, click the question mark in the upper right-hand corner of the screen and then click the option.

To use the What’s This Help for a menu command or toolbar button, click What’s This? on the Help menu, and then click the element you want information about.

**Starting MachineShop** MachineShop is a Windows-base program designed to run in the Microsoft Windows environment.

**To start MachineShop, complete the following steps:**
1. Click **Start** on the Taskbar.
   The Start menu opens.
2. Select **MachineShop** from the Programs folder.
   The MachineShop folder opens.
3. Click **MachineShop Toolbar**.

   **Note**  If you have a shortcut defined, double-click on the **MachineShop Toolbar** icon on your Windows desktop.

   The MachineShop Toolbar and Welcome dialog appear on your screen as shown below.

   The Welcome dialog is designed to guide you through the process of creating a project, opening an existing project, opening and downloading an existing project to the runtime system, and restoring a MachineShop project to the runtime system.

   The Welcome dialog will display on your screen each time you start MachineShop unless you select the **Don’t display this startup screen again** box. You may turn the Welcome dialog back on at anytime by selecting the **Show welcome dialog on startup** box in the Options dialog.
MachineShop User Interface

The MachineShop user interface consists primarily of a toolbar that appears at the top of the Windows desktop by default. You can drag and drop the toolbar to any location on the screen.

To drag the Toolbar to another location, complete the following steps:

1. Position the mouse cursor over the MachineShop Toolbar.
2. Click and drag the Toolbar to the desired screen location.

You may also set the visibility of the toolbar using the Options command on the Tools menu. See Chapter 7 to learn how to set the visibility.

Menus

MachineShop provides conventional Windows menus that are used to gain access to the variety of functions available in MachineShop. The commands you will use most frequently are also displayed on the toolbar.

File Menu

The File menu allows you to create a new project, open an existing project, and close an open project. It also allows you to delete projects and define the location where MachineShop project information will be stored.

Edit Menu

Enabled with open projects, the Edit menu allows you to view or modify the description and the MachineLogic I/O interface for the current project. You can also change your MachineLogic Memory model and port assignment for the current project.

View Menu

The View menu allows you to view information about the current project. Available information includes the project name, location, description, size, as well as information specific to projects that contain Interact and/or MachineLogic. It also allows you to view a list of runtime systems that are currently connected to the development system using a MachineShop Net LAN connection.
MachineShop Net is a type of connection between development and runtime systems. The simplest MachineShop Net connection is a single development system connected to a single runtime system via a serial cable; however, multiple development and runtime systems can be connected to one another via a Local Area Network (LAN).

Tools Menu

The Tools menu allows you to create or restore backups for current projects or projects located on a remote system. It also allows you to customize and configure MachineShop. You may add, edit, or remove a suite component to MachineShop. When you add a suite component, MachineShop adds a button to the MachineShop Toolbar and a command to the Tools menu. Selecting either the command or the button launches the associated application.

See Chapter 7 for a complete discussion on adding, editing, and removing suite components.

Transfer Menu

The Transfer menu is used to download a project (and project components) to or upload a project from a remote system. It is also used to select, add, edit, or remove the connections that will be used for transferring projects between MachineShop and a remote workstation.

Window Menu

The Window menu allows you to close Interact and MachineLogic.

Help Menu

The Help menu includes the commands for finding help on MachineShop. This includes opening the help window, using the context-sensitive help, and connecting to the CTC Parker website. The Help menu also includes commands for viewing help for each of the I/O drivers supported by MachineLogic.
Toolbars

Toolbars provide quick access to the commands you use most often in MachineShop. The MachineShop Toolbar is comprised of three smaller toolbars called rebars. A rebar is the individual segments of a toolbar. Rebars can be repositioned within a toolbar by clicking and dragging them with the mouse.

The three rebars on the MachineShop Toolbar are: the Project Management Rebar, the Suite Navigation Rebar, and the Transfer Rebar.

Project Management Rebar

The Project Management Rebar is used to execute project-related commands that you would otherwise select from the MachineShop File, Tools, and Help menus.

Suite Navigation Rebar

The Suite Navigation Rebar is used to launch applications that you would otherwise launch from the MachineShop Tools menu or from the Windows Start menu. By default, Interact and Machine-Logic are always available from this rebar if they have been installed.

When a MachineShop project has been opened, the selected program will launch with the proper application already loaded. Once Interact and MachineLogic have been launched, you can quickly switch back and forth between them by selecting their toolbar button.

Additional buttons can easily be added to the Suite Navigation Rebar. See Chapter 7 for instructions on how to add and remove buttons.
Transfer Rebar

The Transfer Rebar is used to execute transfer-related commands that you would otherwise select from the MachineShop Transfer menu.

Chapter Summary

In this chapter you have learned about the system requirements for the MachineShop development and runtime systems. You also learned the how to use the Security Key Utility to program your Security Key and you were introduced to the MachineShop Toolbar.

In the next chapter, you will learn how to use the MachineShop Toolbar to create and manage your own projects.
Managing Projects

Once you become familiar with the user interface, you can begin creating and managing projects which use Interact applications and MachineLogic projects. This chapter will show you how to create a project, open and edit a project, and view project information. It also describes the directory structure of the MachineShop projects.

Chapter Contents

- Overview of MachineShop Projects 26
- Create a New Project 28
- Open an Existing Project 32
- Save a Project 33
- Delete a Project 34
- View Project Information 35
- Edit a Project 36
- Chapter Summary 38
Overview of MachineShop Projects

A MachineShop project is a collection of related files and applications that you create on a development system and download to a runtime system. The purpose of a project is to group all the necessary files for HMI, PC based logic control, and special user defined startup programs for a machine control application together under a single name. You can create multiple projects on the development system to maintain various configurations of a runtime system’s tasks, but only one project can reside on a runtime system at one time.

Creating a new project is very simple in MachineShop. MachineShop includes a New Project Wizard to guide you through the process of creating a project. Each project contains a specific set of files for running Interact applications and managing machine control programs.

Project Directory Structure

Projects are kept in a subdirectory named “Projects” under the MachineShop directory. Each project that is made has its own subdirectory. Project directories for Interact projects are created and stored under the \PROJECTS\INTERACT directory. Project directories for MachineLogic projects are created and stored under the \PROJECTS\MACHLOG directory.

The project directory structure is illustrated below:

```
C:\MACHSHOP
 \PROJECTS
  \CONFIG
  \INTERACT
   \PROJ_1
    \APPFILES
    \STARTUP
   \PROJ_2
   \PROJ_3
  \MACHLOG
   \PROJ_1
   \PROJ_3
  \TUTORIAL
```

The CONFIG directory holds the MachineLogic Runtime configuration files. The APPFILES directory holds subdirectories for each application you create for your Interact project and the STARTUP directory holds any extra AUTOEXEC.BAT files or driver system files, network initialization files, etc.
Startup Files

A runtime workstation may require its own set of “startup files”, such as the autoexec.bat or config.sys files, for loading system drivers or terminate-stay-resident programs (TSRs) into memory prior to running Interact. System drivers usually have a “.sys” extension and are loaded by a command placed in the config.sys file. TSRs are typically loaded by a command in the autoexec.bat file.

You can create your own startup files and copy these along with any needed programs, such as drivers or TSRs, into the project’s \STARTUP directory. These files will be sent to the runtime workstation during a project download.

Setting the Project Path

You may define the location where MachineShop projects will be stored by selecting the Project Path command from the File menu. This path is set to MACHSHOP\PROJECTS by default.

**Note** You cannot change the project path while a project is open in MachineShop.

To change the project path, complete the following steps:

1. Select the **Project Path** command from the File menu.
   
   The Project Path dialog box appears.

2. Browse to the location on your hard drive where you want MachineShop to store project files.

3. Click **OK**.
Create a New Project

You are now ready to create a project. MachineShop provides a New Project Wizard to guide you through the process.

**To create a new project, complete the following steps:**

1. Select the **New Project** command from the File menu or click the **New Project** button in the toolbar.
   
   The New Project dialog box appears.

2. Enter the name of the project.

3. Enter a project description.

4. Select the applications (Interact and/or MachineLogic) that you want to use.

5. Click **OK** to accept these changes.

   The New Project Wizard appears. If MachineLogic is part of the project, then the following window appears. If MachineLogic is not part of the project, skip to step 8.

   ![New Project Wizard - Step 1](image)

6. Select one of the following templates from the list of available templates, and then click **Next**.
   - Template for UCS DeviceNet - includes global variables and I/O configuration for a UCS DeviceNet I/O driver.
   - Template for SST ProfiBus - includes global variables and I/O configuration for an SST Profibus I/O driver.
• Template for Simulated I/O - includes global variables and I/O configuration for simulating a MachineLogic project on your development PC.

• Template for Dummy I/O - includes global variables and I/O configuration for an application that does not communicate with I/O devices. This allows you to debug your application prior to putting the control online.

• Template for Tutorial - includes global variables and I/O configuration for the MachineLogic Tutorial.

The following window appears.

7. Select the I/O interface that you want to use in your MachineLogic application.

Make sure the I/O interface matches the hardware installed in the runtime system.

8. Click **Next** if Interact is part of your project. Otherwise, click **Finish** and skip to step 11.
If Interact is part of the project, the following window appears.

9. Enter a name and select the display resolution for your Interact application.
   The name can be eight characters or less.

10. Click **Next** to select the modules you want to use in your Interact application.
    The following window appears.

11. Double-click the modules in the list that you want to use in your Interact application.
12. Click **Next** to select the drivers you want to use in your Interact application.

   The following window appears.

   ![New Project Wizard - Step 3 of 3](image)

13. Double-click the drivers in the list that you want to use in your Interact application.

14. Click **Finish** when you are finished selecting the drivers.

   The New Project Information dialog box appears.

   ![New Project Information](image)

   The New Project Information dialog box displays the options you have chosen using the New Project Wizard.
Open an Existing Project

Chapter 3: Managing Projects

15. Click **OK** to create the project using these options, or click **Cancel** to return to the last page of the New Project Wizard.

16. Once the project is created, select the appropriate command from the Tools menu or click the appropriate button on the toolbar to launch MachineLogic or Interact.

The program will open with the proper application ready for development.

Before developing your Interact application and/or MachineLogic project, you must open your project using the MachineShop Toolbar. Once the project is open, you can then launch Interact or MachineLogic.

**Note** Project files use the .WMS extension. Each time you select the Open Project command, MachineShop searches the project directory for Interact or MachineLogic application files that are not part of a MachineShop project. If files are found, MachineShop displays a message asking if you would like to create a MachineShop project file.

**To open a project, complete the following steps:**

1. Select the **Open Project** command from the File menu, or click the **Open Project** button on the toolbar.

   The Open Project dialog box appears.

2. Browse to the location on your hard drive that contains the project file.

   Project files use the .WMS extension.
3. Click **Open** to open the project.
4. Select the appropriate command from the Tools menu or click the appropriate button on the toolbar to launch Interact or MachineLogic.

The program will open with the proper application ready for development.

### Save a Project

You may save the current project to a local or network location. By default, the location is the current path setting set using the Project Path command.

**To save a project, complete the following steps:**

1. Select the **Save Project As** command from the File menu. The Save Project As dialog box appears.

2. Browse to the location on your hard drive where you want to save the project.

   Project files use the `.WMS` extension.

3. Enter the name of the project in the File name box.
4. Click **Save** to save the project.
Delete a Project

You may delete any existing MachineShop project from any location using the Delete Project command. The Delete Project command also deletes the Interact and MachineLogic files associated with the project as well as your startup files.

To delete a project, complete the following steps:

1. Select the Delete Project command from the File menu.

   The Delete Project dialog box appears.

2. Browse to the location on your hard drive that contains the project you want to delete.

   Project files use the .WMS extension.

3. Enter the name of the project in the File name box.

4. Click Delete to delete the project.

   Note You cannot delete a project if it is open in MachineShop.

   The Confirm Project Deletion dialog box appears.

5. Click Yes to delete the project.
View Project Information

You may view information about the active project on your local system using the Project Information command. This includes startup files, Interact drivers and modules used, MachineLogic application information, and version numbers for Interact and MachineLogic development and runtime components.

To view local project information, complete the following steps:

1. Open the project if you haven’t already.
2. Select the **Project Information** command from the View menu or click the Project Information button on the toolbar.
   The Project Information property sheet appears.

3. Click on one of the following tabs to view the available information for this project:
   - **Project** - Displays the name of the project, the location where this project is stored, the description, and the size of the individual components of this project.
   - **Startup Files** - Displays the names of the startup files (if any) located in the startup folder of this project.
   - **Interact** - Displays the names of the modules, drivers, and Interact applications used in this project.
Edit a Project

Chapter 3: Managing Projects

MachineLogic - Displays the names of the I/O interface and the MachineLogic programs used in this project.

Versions - Displays the version numbers for Interact and MachineLogic development and runtime components used by this project.

Note  The Interact and MachineLogic tabs are available only when they are part of the project.

4. Click OK or Cancel to close the Project Information property sheet.

Edit a Project

You may view or edit the project description and the I/O interface for the active project using the Edit menu. You may also modify the MachineLogic Memory and port assignment for the active project.

Project Description

Use the Project Description command on the Edit menu to view or modify the description for the current project.

To modify the project description, complete the following steps:

1. Open the project if you haven’t already.

2. Select the Project Description command from the Edit menu.

The Project Description dialog box appears.

3. Enter or edit a description in the Project Description area.

4. Click OK to accept the new or modified description, or Cancel to return to the previous description.
**I/O Interface**  
Use the I/O Interface command on the Edit menu to view or modify the MachineLogic I/O interface for the current project. The I/O interface refers to the hardware and software that is necessary to communicate between a PC running MachineLogic and a device or machine that is being controlled by that PC.

**To modify the I/O interface, complete the following steps:**
1. Open the project if you haven’t already.
2. Select the **I/O Interface** command from the Edit menu. The Edit I/O Interface dialog box appears.
3. Select the I/O interface from the list of available interfaces.
4. Click **OK** to accept the new I/O interface or **Cancel** to return to the previous interface.

**Memory and Ports**  
Use the Memory and Ports command on the Edit menu to modify the MachineLogic Memory model and serial port assignment for the current project. The Memory model refers to the amount of memory reserved for the control logic program size and the amount of memory reserved for system data.

**To modify the Memory and Port assignment, complete the following steps:**
1. Open the project if you haven’t already.
2. Select the **Memory and Ports** command from the Edit menu.
Chapter Summary

The Memory and Ports dialog box appears.

3. Enter a value for the Total Memory Size and Program Size.
4. Select the serial port assigned to this project.
5. Click **OK** to accept the new Memory and port assignment or **Cancel** to return to the previous assignment.

In this chapter you have learned how to create and manage your own projects. You also learned about MachineShop projects and the project directory structure.

In the next chapter, you will learn how to add connections that will be used for transferring projects between MachineShop and a remote workstation.
Adding Connections

Before you can transfer files to the runtime system, you must create a transfer connection in MachineShop. A connection refers to the method used to transfer files to or from a runtime system. The type of connections available are MachineShop Network, IPM Compatible Serial and disk transfers. The MachineShop Network connection allows you to communicate with a runtime system using a serial cable, Ethernet point to point or over a LAN.

Multiple connections can be defined for different types of connections. Connections can even be defined with the same connection type, but for different target runtime systems.

This chapter provides instructions on how to set up MachineShop Network Connections for a LAN, serial, Ethernet point to point, and modem connection. It also describes how to add an IPM Compatible Serial and disk transfer connection.

Chapter Contents

| MachineShop Net Connections          | 40 |
| IPM Compatible Connection           | 58 |
| Disk Transfer Connection             | 60 |
| Chapter Summary                      | 61 |
MachineShop
Net Connections

The MachineShop Network connection allows the development system to communication with a runtime system using Ethernet point to point, over a LAN, through a serial cable, or via modem.

All MachineShop Net communications require the Transmission Control Protocol/Internet Protocol (TCP/IP) communications protocol. CTC chose this protocol because it is the primary communications protocol being used today. As its name implies, this is the same protocol that is the basis for Internet communications—email (SMTP), file transfer (FTP), and most notably, the World Wide Web (HTTP).

Additionally, serial and modem connections require Dial-Up Networking, and an Ethernet point to point connection requires you to configure the Ethernet card’s TCP/IP properties.

This section describes how to add MachineShop Net connections for a LAN, Ethernet point to point, serial, and modem connection.

LAN Connection

Using the MachineShop Net connection you can connect a development system to a runtime system through a Local Area Network (LAN). LAN communications are the preferred method of communication because they offer the fastest rates and the greatest flexibility.

To add a LAN connection in MachineShop, complete the following steps:

1. Open MachineShop.
2. Select the Add Connection command from the Transfer Menu or click the Add Connection button on the toolbar. The New Connection dialog box appears.
3. Enter a name for this connection.
4. Select **MachineShop Net (Serial/LAN)** as the connection type.

5. Click **OK** to accept these choices.

   The New Connection Wizard appears.

6. Select **LAN** as the network connection type.

7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.

   The Network Details dialog box appears.
8. Select one of the following options:

- **IP Address** - Select this option to specify the IP address of a runtime system. Enter the IP address in the top box of the Name group.

- **MachineShop Net Name** - Select this option to specify a runtime system by name. This is the name you entered using the MachineShop Shell/Settings/TCP/IP/Net Name command.

  MachineShop automatically displays the names that it is able to detect in the list box. Select a name from the list.

**Note** The runtime system must be configured and connected for it to appear in the MachineShop Net Name list.

- **Host Name** - Select this option to specify the host name, such as www.ctcusa.com, of the runtime system. This option requires a network with a domain name server (DNS). Your network administrator must also configure a host name to match the IP address of the runtime system prior to using this option.

9. Click **OK** to accept these choices.

   You are returned to the New Connection Wizard.

10. Click **Next** to continue.

   The following window appears.
11. Enter a user name and password only if an FTP user name and password was entered on the runtime system. The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Select Yes to enable passive transfers. Otherwise, select No. Passive transfers allow MachineShop to connect to an FTP server when the MachineShop Toolbar is behind a firewall. In most cases, you will NOT need passive transfers.

13. Click Finish to create the connection.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit command from the Transfer menu.

Ethernet Point to Point Connection

Using the MachineShop Net connection you can connect a development system to a runtime system through an Ethernet patch cable. In addition to adding the connection in MachineShop, you must configure the TCP/IP properties for the Ethernet card.

This section describes how to configure the TCP/IP properties and add the connection in MachineShop.

Configure TCP/IP Properties in Windows 95/98

Use the Network option in the Windows Control Panel to configure the Ethernet card’s TCP/IP properties.

Note You may be asked to insert Windows installation disk(s) or CD-ROM after making the adjustment.

To configure the TCP/IP properties in Windows 95/98, complete the following steps:

1. Double-click the Network icon in the Windows Control Panel.
The Network control property sheet appears.

2. Click the **Configuration** tab if it is not already in view.

   The Configuration tab appears.

3. Select the TCP/IP network component for your Ethernet card from the list of components and then click **Properties**.
The TCP/IP property sheet appears.

4. Click the **IP Address** tab if it is not already in view.
   The IP Address tab appears.

5. Select **Specify an IP Address** and then enter the IP address and IP mask for the development system.
   CTC recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP mask.
   
   **Note**  If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

6. Click the **Advanced** tab.
The Advanced tab appears.

![TCP/IP Properties dialog box]

7. Select **Set this protocol to be the default** at the bottom of the screen.

8. Click **OK** to accept these choices.

   The Network control property sheet appears.

9. Click **OK** to exit the Network control property sheet.

You are now ready to add the connection in MachineShop. See *Add Connection in MachineShop* on page 49 for instructions.

**Configure TCP/IP Properties in Windows NT**

Use the Network option in the Windows Control Panel to configure the Ethernet card’s TCP/IP properties.

**To configure the TCP/IP properties in Windows NT, complete the following steps:**

1. Double-click the **Network** icon in the Windows Control Panel.
The Network control property sheet appears.

2. Click the **Protocols** tab.

The Protocol tab appears.
3. Select **TCP/IP Protocol** from the list of Network Protocols and then click **Properties**.

The Microsoft TCP/IP property sheet appears.

4. Click the **IP Address** tab if it is not already in view.

The IP Address tab appears.

5. Select the Ethernet adapter for your card from the list of adapters.

6. Select **Specify an IP address** and then enter the IP address and IP mask for the development system.

   CTC recommends that you enter 10.0.0.1 as the IP address and 255.255.255.0 as the IP mask.

   **Note**  
   If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

7. Click **OK** to accept these choices.

The Network control property sheet appears.
8. Click **OK** to exit the Network property sheet.

You are now ready to add the connection in MachineShop.

### Add Connection in MachineShop

Once you have configured the TCP/IP properties for the Ethernet card, you can add the connection in MachineShop.

**To add an ethernet point to point connection in MachineShop, complete the following steps:**

1. Open MachineShop.

2. Select the **Add Connection** command from the Transfer menu.

   The New Connection dialog box appears.

3. Enter a name for this connection.

4. Select **MachineShop Net (Serial/LAN)** as the connection type.

5. Click **OK** to accept these choices.
The New Connection Wizard appears.

6. Select **LAN** as the network connection type.
7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.

The Network Details dialog box appears.

8. Select **IP Address** and then enter the IP address of the runtime system in the top box of the Name group.

Typically the IP address for the runtime system is 10.0.0.2.

9. Click **OK** to accept your entries.

You are returned to the New Connection Wizard.
10. Click **Next** to continue.

   The following window appears.

   ![Connection Wizard Window](image)

11. Enter a user name and password only if an FTP user name and password was entered on the runtime system.

   The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Click **Finish** to create the connection.

13. Connect the development system to the Ethernet connector using a cross-over 10Base-T cable.

   You are now ready to transfer projects that you create in MachineShop to a runtime system. See **Chapter 3** for details on creating projects and **Chapter 6** for details on transferring files.

   If you need to make changes to the connection simply select the **Edit Command** from the **Transfer** menu.
Serial Connection

Using the MachineShop Net connection you can connect the development system to a runtime system using a serial cable with hardware handshaking. MachineShop uses a specific dial-up entry named “MachineShop Phonebook Entry” to communicate with the runtime system. The MachineShop Phonebook Entry is created when you install MachineShop. For details on the MachineShop installation program, see the *MachineShop Installation Booklet*.

To add a serial connection in MachineShop, complete the following steps:

1. Open MachineShop.
2. Select the *Add Connection* command from the Transfer menu or click the *Add Connection* button on the toolbar. The New Connection dialog box appears.
3. Enter a name for this connection.
4. Select *MachineShop Net (Serial/LAN)* as the connection type.
5. Click *OK* to accept these choices.
The New Connection Wizard appears.

6. Select **Direct Connection (Serial)** as the network connection type.

   **Note** This option uses a specific dial-up entry named “MachineShop Phonebook Entry”. This entry should have been created by the MachineShop installation program.

   If the installation program could not create the MachineShop Phonebook Entry, the Direct Connection option will not be available. See Appendix A for instructions on how to manually create the MachineShop Phonebook Entry.

7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.
8. Select **IP Address** and then enter the IP address of the runtime system in the top box of the Name group.

Typically the IP address for the runtime system is 10.0.0.2.

9. Click **OK** to accept these choices.

You are returned to the New Connection Wizard.

10. Click **Next** to continue.

The following window appears.

11. Enter a user name and password only if an FTP user name and password was entered on the runtime system.
The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Click Finish to create the connection.

13. Connect the serial cable to the appropriate serial port of the development system.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.

**Modem Connection**

The MachineShop Net Connection also allows a remote computer to connect to a runtime system through a modem. This connection uses Windows Dial-Up Networking to dial into a LAN-based remote access server.

You must configure Dial-Up Networking in order to dial into the remote access server. Dial-Up Networking is available from the My Computer icon on the Windows desktop. Once you have created and configured the dial-up connection, you can add the connection in MachineShop.

**To add a modem connection in MachineShop, complete the following steps:**

1. Open MachineShop.

2. Select the Add Connection command from the Transfer menu or click the Add Connection button on the toolbar.

   The New Connection dialog box appears.

3. Enter a name for this connection.
4. Select **MachineShop Net (Serial/LAN)** as the connection type.

5. Click **OK** to accept these choices.

   The New Connection Wizard appears.

   ![New Connection Wizard](image)

6. Select **Dial-Up Networking** as the network connection type and then select the dial-up entry from the list box.

   The list box displays the available dial-up entries that you can associated with this connection. These entries are created using Windows Dial-Up Networking available from the My Computer icon on the Windows desktop. See Appendix A for instructions on creating and configuring a MachineShop dial-up connection.

7. Select **Define runtime system now** and then click **Details** to define the specific parameters for the target runtime system.
The Network Details dialog box appears.

8. Select **IP Address** and then enter the IP address of the runtime system in the top box of the Name group.

   This is the IP address of the runtime system assigned by the network. Check with your local network administrator to determine a valid IP Address to be used on your local network.

9. Click **OK** to accept your entries.

   You are returned to the New Connection Wizard.

10. Click **Next** to continue.

   The following window appears.
11. Enter a user name and password only if an FTP user name and password was entered on the runtime system.

The user name and password must match what was entered on the runtime system using the MachineShop Shell/Settings/FTP commands for you to gain access to the runtime system.

12. Select Yes to enable passive transfers. Otherwise, select No.

Passive transfers allow MachineShop to connect to an FTP server when the MachineShop Toolbar is behind a firewall. In most cases, you will NOT need passive transfers.

13. Click Finish to create the connection.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See Chapter 3 for details on creating projects and Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.

---

**IPM Compatible Connection**

The Interact IPM Compatible Serial connection is used to transfer projects to a CTC PowerStation that has the PowerStation Shell installed on it. This connection supports the transfer of Interact projects only, and is supplied for backward compatibility with existing systems. The Interact IPM Compatible connection uses a serial port connection between the MachineShop development system and the PowerStation.

**Note** This connection replaces IPM connectivity. IPM is a DOS based utility that is optimized for handling serial ports and the transfer of files through them. This connection will provide the same capability as IPM. Due to the addition of overhead in handling of serial ports in the Windows environment, the length of time necessary to transfer files with this connection may increase from the transfer times when using IPM.

**To add an Interact IPM Compatible connection, complete the following steps:**

1. Open MachineShop.
2. Select the Add Connection command from the Transfer menu or click the Add Connection button on the toolbar.
Chapter 4: Adding Connections

The New Connection dialog appears.

3. Enter a name for this connection.
4. Select **IPM Compatible (Serial)** as the connection type.
5. Click **OK** to accept these choices.

The New Connection Wizard appears.

6. Select the COM port and baud rate you will be using in this connection.
7. Click **Finish** to create the connection.

You are now ready to transfer Interact projects to a CTC PowerStation that has the PowerStation Shell installed on it. See Chapter 6 for details on transferring files.

If you need to make changes to the connection simply select the Edit Command from the Transfer menu.
Disk Transfer Connection

Files may be transferred directly to a Compact FLASH or network drives using the Disk Transfer connection.

To add a disk transfer connection, complete the following steps:

1. Open MachineShop
2. Select the Add Connection command from the Transfer menu or click the Add Connection button on the toolbar.
   The New Connection dialog box appears.

3. Enter a name for this connection.
4. Select Disk as the connection type.
5. Click OK to accept these choices.
   The New Connection Wizard appears.
6. Select the letter of the drive you will be using in this connection.
   You may select any removable drive such as a floppy drive, Compact FLASH, or Zip drive.

7. Click **Finish** to create the connection.

You are now ready to transfer projects that you create in MachineShop to a runtime system. See *Chapter 3* for details on creating projects and *Chapter 6* for details on transferring files.

If you need to make changes to the connection, simply select the Edit Connection command from the Transfer menu.

---

In this chapter you have learned how to prepare the development system for file transfers. This includes setting up a LAN, serial, Ethernet point to point, and modem connection. You also learned how to add an IPM Compatible Serial and disk transfer connection.

In the next chapter, you will learn how to use MachineShop to create and restore backups for current projects or projects located on a runtime system.
Chapter 5

Backing Up Projects

MachineShop provides a wizard for backing up and restoring projects to and from runtime workstations or a variety of storage devices (diskette, Compact Flash, hard drive, network, etc.). This chapter describes how to create and restore a project backup for a current project or a project located on a runtime system. It contains both descriptive information and step-by-step instructions.

Chapter Contents

Creating a Backup 64
Restoring a Backup 67
Chapter Summary 72
Creating a Backup

MachineShop provides a Backup Wizard to guide you through the process of backing up a local project or a project on a runtime system to a selected target. The target can be a variety of storage devices including diskette, Compact Flash, hard drive, or network.

Projects are compressed into a subdirectory with the same name as the project. After the project is backed up, the file names are appended with a .zip suffix.

Local Project Backup

You may backup the current project on the development system using the Project command from the Create Backup submenu. This command will launch the Backup Wizard.

To backup a local project, complete the following steps:

1. Open the project if you haven’t already.
2. Select the Create Backup command from the Tools menu. The Create Backup submenu appears.
3. Select the Project command from the Create Backup submenu. The Backup Wizard appears.
4. Enter the full path including the drive letter where you want to store this backup.
5. Select the components that you want to include in the backup:
   - Runtime Program Files - includes the Interact and MachineLogic runtime program files.
   - Application Files - includes the Interact and MachineLogic application files in the backup.
   - MachineLogic Source Backup - includes the zip (.ZWT) file of the MachineLogic source files in the backup.

   **Note** The MachineLogic Source Backup option is only available if you have created the zip (.ZWT) file for the project using the “Save Project/Zip Project as” command in MachineLogic.

6. Click **Finish**.
   The Backup Project Information window appears.

   ![Backup Project Information](image)

7. Click **OK** to backup the active project on the development system.
   The Backing Up dialog box appears.
8. Click **Close** when the backup operation is done.
Remote Project Backup

You may backup an active project on a runtime system using the Remote System command from the Create Backup submenu. This command will launch the Backup Wizard.

**Note** You must create the connection you plan to use to communicate with the runtime system before you can create the remote project backup. See Chapter 4 for information on adding connections.

**Important** You can only back up projects on the runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

**To backup a project on a runtime system, complete the following steps:**

1. Select the **connection** you want to use from the Select Connection box on the MachineShop Toolbar.
2. Select the **Create Backup** command from the Tools menu.
   
   The Create Backup submenu appears.
3. Select the **Remote System** command from the Create Backup submenu.
   
   The Backup Wizard appears.

4. Enter the full path including the drive letter where you want to store this backup.
5. Select the components that you want to include in the backup:
   - Runtime Program Files - includes the Interact and MachineLogic runtime program files.
   - Application Files - includes the Interact and MachineLogic application files in the backup.
   - MachineLogic Source Backup - includes the zip (.ZWT) file of the MachineLogic source files in the backup.

6. Click **Finish** to backup up the project on the runtime system.
   The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

7. Click **Close** when the backup operation is done.

**Restoring a Backup**

MachineShop provides a Restore Wizard to guide you through the process of restoring a project backup to either the development or runtime system. The backup may be located on a variety of storage devices including diskette, Compact Flash, hard drive, or network.

**Restore Backup to the Local System**

You may restore a project from a selected source to the development system using the Project command from the Restore Backup submenu. This command will launch the Restore Wizard. The Restore Wizard will automatically decompress the backup and restore it to the location set in the Project Path dialog box.

**To restore a project backup to the development system, complete the following steps:**

1. Select the **Restore Backup** command from the Tools menu.
   The Restore Backup submenu appears.

2. Select the **Project** command from the Restore Backup submenu.
The Restore Wizard appears.

3. Enter the full path including the drive letter where the backup is stored.
4. Select the project you want to restore from the list of project backups.
5. Click **Next**.
   The following window appears.

6. Select the components of the project that you want to include in the restoration and then click **Finish**.
The Restore Project Information window appears.

7. Click OK to restore the project on the development system. The Restore dialog box appears.

   **Note**  If there is a current project with the same name as the project backup, the Restore Project dialog box appears. The Restoration process will delete the current project before it restores the backup. To continue the restoration process, click Restore. To rename the current project first, click Rename, or to exit the restoration process, click Cancel.

8. Click Close when the restore operation is done.
Restore Project to a Remote System

You may restore a project backup from a selected source to a runtime system using the Remote System command from the Restore Backup submenu. This command will launch the Restore Wizard. The Restore Wizard will automatically decompress the project backup and load it on the runtime workstation.

Note You must create the connection you plan to use to communicate with the runtime system before you can restore a project to it. See Chapter 4 for information on adding connections.

Important You can only restore backup projects to the runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

To restore a project backup to a runtime system, complete the following steps:

1. Select the connection you plan to use from Select Connection box on the MachineShop Toolbar.
2. Select the Restore Backup command from the Tools menu.
   The Restore Backup submenu appears.
   The Restore Wizard appears.
4. Enter the full path including the drive letter where the backup is stored.

5. Select the project you want to restore from the list of project backups.

6. Click Next.

   The following window appears.

   ![Restore Wizard - Step 2 of 2]

   What components of the project would you like to restore?
   - [ ] Run-time Program Files
   - [ ] Application Files
   - [ ] MachineShop Source Backup

7. Select the components of the project that you want to include in the restoration and then click Finish.
The Restore Remote Information window appears.

8. Click **OK** to restore the project on the runtime system.

   The Transferring dialog box appears on the screen. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

9. Click **Close** when the restore operation is done.

**Chapter Summary**

In this chapter you have learned how to create and restore project backups. This included current projects and projects located on the runtime system.

In the next chapter, you will learn how to use MachineShop to download a project to and upload a project from a remote system.
Chapter 6

Transferring Projects

Once an application has been developed and a connection created, you can transfer the files needed to create or update a runtime system. MachineShop provides a Transfer Wizard to step you through the process of selecting a connection and transferring the files to and from a runtime system.

This chapter provides instructions on how to download and upload an active project from the development system to a runtime system. This includes using the Transfer Wizard and the Download and Upload commands.

Chapter Contents

- Downloading a Project 74
- Uploading a Project 78
- Chapter Summary 81
Downloading a Project

Downloading refers to the process of transferring project files from a development system to a runtime system. There are two ways to download files in MachineShop: the Transfer Wizard and the Download command. This section describes how to use the two methods to download files to the runtime system.

**Important** You can only download project files to a runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

**Transfer Wizard**

The Transfer Wizard steps you through the process of selecting the transfer connection and downloading the project files to a runtime system.

To download a project to a runtime system using the Transfer Wizard, complete the following steps:

1. Open the project if you haven’t already.
2. Select the **Transfer Wizard** command from the Transfer menu.

   The Transfer Wizard appears.

3. Select **Download to Runtime** to download the project to the runtime system.
4. Click **Next** to continue.
5. Select the connection you want to use to transfer the files from the list of connections. You may also create a connection from here. Click Define New Connection and follow the instructions provided by the New Connection Wizard. See Chapter 4 for more information on how to add a new connection.

6. Click Next to continue.

The following window appears.
7. Select **Complete Project** to download the entire project to the runtime system.

   If you do not want to download the entire project, clear the Complete Project check box; then select the files you want to download from the Components group box.

   **Note** Application Files also include the MachineLogic source file (.ZWT file) if MachineLogic is part of the project. MachineShop expects this file to be in the project directory. If this file is not in the project directory, a warning message will appear notifying you that the file does not exist when you click Finish.

8. Select **All Files** to download all of the files or **Update Files Only** to download only the files that have changed since the last download.

9. Click **Finish** to download the project files to the runtime system.

   The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

**Download Command**

You can also use the Download command to download project files on the development system to a runtime system.

   **Note** You must create the connection you plan to use to communicate with the runtime system before you can use the Download command. See Chapter 4 for information on adding connections.

**To download a project to the runtime system using the Download command, complete the following steps:**

1. Open the project if you haven’t already.

2. Select the connection you want to use to transfer the files from the Select Connection box on the toolbar.

3. Select the **Download** command from the Transfer menu or click the **Download** button on the toolbar.
Chapter 6: Transferring Projects

Downloading a Project

The Download dialog box appears.

4. Select **Complete Project** to download the entire project to the runtime system.
   
   If you do not want to download the entire project, clear the Complete Project check box; then select the files you want to download from the Components group box.
   
   **Note** Application Files also include the MachineLogic source file (.ZWT file) if MachineLogic is part of the project. MachineShop expects this file to be in the project directory. If this file is not in the project directory, a warning message will appear notifying you that the file does not exist when you click Finish.

5. Select **All Files** to download all of the files or **Update Files Only** to download only the files that have changed since the last download.

6. Click **Download** to download the project files to the runtime system.

   The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.
Uploading a Project

Uploading refers to the process of transferring a project from a runtime system to a development system. Like Downloading, there are two ways to upload files in MachineShop: the Transfer Wizard and the Upload command. This section describes how to use the two methods to upload project files from the runtime system.

**Important** You can only upload project files from a runtime system when the MachineShop Shell’s Main Menu is displayed on the screen.

**Transfer Wizard**

The Transfer Wizard steps you through the process of selecting the transfer connection and uploading the project files from the runtime system.

To upload a project from the runtime system using the Transfer Wizard, complete the following steps:

1. Select the **Transfer Wizard** command from the Transfer menu.

   The Transfer Wizard appears.

2. Select **Upload from Runtime** to upload a project from the runtime system.

3. Click **Next** to continue.
Chapter 6: Transferring Projects

Uploading a Project

The following window appears.

4. Select the connection you want to use to transfer the files from
the list of connections.

You may also create a connection from here. Click **Define New Connection** and follow the instructions provided by the New Connection Wizard. See Chapter 4 for more information on how to add a new connection.

5. Click **Next** to continue.

6. The following window appears.
7. Select Complete Project to upload the entire project to the runtime system.
   If you do not want to upload the entire project, clear the Complete Project check box; then select the files you want to upload from the Components group box.

8. Select All Files to upload all of the files or Update Files Only to upload only the files that have changed since the last upload.

9. Click Finish to upload the project files from the runtime system.

The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

**Upload Command**

You may also use the Upload command to upload files from the runtime system to the development system.

**Note** You must create the connection you plan to use to communicate with the runtime system before you can use the Upload command. See Chapter 4 for information on adding connections.

**To upload a project from the runtime system using the Upload command, complete the following steps:**

1. Select the connection you plan to use to transfer the files from Select Connection box on the toolbar.

2. Select the Upload command from the Transfer menu or click the Upload button on the toolbar.
The Upload dialog box appears.

![Upload dialog box]

3. Select **Complete Project** to upload the entire project to the runtime system.

   If you do not want to upload the entire project, clear the Complete Project check box; then select the files you want to upload from the Components group box.

4. Select **All Files** to upload all of the files or **Update Files Only** to upload only the files that have changed since the last upload.

5. Click **Upload** to upload the project files from the runtime system.

The Transferring dialog appears. It displays the current file being transferred, the direction, and the estimated time remaining in the transfer.

---

**Chapter Summary**

In this chapter you have learned how to download and upload project files to and from the runtime system. This included using the Transfer Wizard and the Download and Upload commands to perform the transfer.

In the next chapter, you will learn how to customize MachineShop to meet your specific needs.
You may customize some of the basic MachineShop operations to suit your needs. This chapter describes how to add frequently used programs to MachineShop, set the visibility of MachineShop on the desktop, and reposition the toolbars.

Chapter Contents

Set the Visibility 84
Move the MachineShop Toolbars 85
Add, Edit, and Remove Suite Components 86
Chapter Summary 88
Set the Visibility

You may determine how MachineShop will appear on your desktop. You may have the MachineShop Toolbar visible at all times or you may have the toolbar automatically hide whenever the mouse pointer is outside the region occupied by the toolbar.

You set the visibility options using the Options command from the Tools menu.

To set the visibility of MachineShop, complete the following steps:

1. Select the Options command from the Tools menu.
   
The Options dialog box appears.

2. Select Always on Top to keep MachineShop on top of all applications.
   
   Note  This option is checked by default and only available when the MachineShop Toolbar is undocked.

3. Select AutoHide to hide MachineShop until you move the mouse into the region occupied by the MachineShop Toolbar.
   
   Note  This option is cleared by default and is only available when the MachineShop Toolbar is docked.

4. Click OK to accept these choices.
Move the MachineShop Toolbars

MachineShop is docked to the top of the Windows desktop by default. You may undock the toolbar by simply dragging it away from the edge. Once the toolbar is undocked, you can move it anywhere on the screen.

To undock the MachineShop Toolbar, complete the following step:

1. Position the mouse cursor over the MachineShop Toolbar.
2. Click and drag the toolbar away from the edge of the Windows desktop.

The toolbar appears as shown below.

![MachineShop Toolbar](image)

To dock the MachineShop Toolbar, complete the following steps:

1. Position the mouse cursor over the MachineShop title bar.
2. Click and drag the toolbar to the top of the Windows desktop.

The toolbar snaps into place along the length of the screen edge.

Move the MachineShop Rebars

The MachineShop Toolbar includes three smaller toolbars called rebars. These rebars can be repositioned on the toolbar by clicking and dragging the small handlebars.

To move the MachineShop rebars, complete the following steps:

1. Position the mouse cursor over the handlebar of the rebar you want to move.
2. Click and drag the rebar to the desired position.
Add, Edit, and Remove Suite Components

You can add, edit, and remove frequently used programs to MachineShop. Once the program is added, you can then launch the program by clicking on the button on the MachineShop Toolbar, or by selecting the command from the Tools menu.

This section describes how to add, edit, and remove programs from MachineShop.

Add a Program

You can add a program to MachineShop using the Add Suite Component command. After you add a program, you will be able to launch the program by clicking on a button on the MachineShop Toolbar or by selecting a command from the Tools menu.

To add a program to MachineShop, complete the following steps:

1. Select the Add Suite Component command from the Tools menu.

   The Add Suite Component dialog box appears.

2. Browse to the location on your hard drive that contains the file you want to add.

   This can be any type of file, for example, an executable (.EXE) file, an Excel (.XLS) file, the configuration file for your I/O driver, etc.

3. Click Open to accept this choice.
**Edit a Program**

You can edit a program on the MachineShop toolbar using the Edit Suite Component command. By editing a program, you will be able to add the capability to pass the program a command line argument when the program launches.

**To edit a program on the MachineShop toolbar, complete the following steps:**

1. Select the **Edit Suite Component** command from the Tools menu.

   The Edit Suite Component dialog box appears.

2. Highlight the icon for the suite component you want to edit.

3. Select the Edit button.

   The Suite Component Properties dialog box appears.

4. In the Command Line text box, enter a command line parameter that will be passed to the application when it is launched.

5. Select the For this Project Only check box if you wish the button to be local to the current project.

   Application buttons are global when first added to the
Toolbar. The command line parameter will be stored in the current project’s .WMS file.

6. Click **OK** to accept the selections.

**Remove a Program**

You can remove a program from the MachineShop that you previously added using the Add Suite Component command. MachineShop removes the associated button and menu command.

**To remove a program from MachineShop, complete the following steps:**

1. Select the **Remove Suite Component** command from the Tools menu.
   
The Remove Suite Component dialog box appears.

2. Select the icon for the program you want to remove.

3. Click **Remove** to accept this choice.

**Chapter Summary**

In this chapter you have learned how to add, edit, and remove programs from MachineShop, reposition the toolbars, and configure the visibility options.

The remainder of this manual includes appendices that provide information on how to manually create the MachineShop Phonebook Entry and construct your own cable.
MachineShop Dial-Up Networking Connections

This appendix describes how to create and configure dial-up networking connections for MachineShop. Dial-Up Networking is available from the My Computer icon on the Windows desktop.

**Note** If you need to modify the TCP/IP settings or the modem’s baud rate for a dial-up connection, see the *Configure the Connection* sections in this appendix. Windows 95/98 instructions start on page 91 and Windows NT instructions start on page 97.

### 95/98 Dial-Up Networking

This section describes the steps to create and configure a dial-up connection in Windows 95/98. See *Windows NT Dial-Up Networking* in this appendix for Windows NT instructions.

**Create a Dial-Up Connection**

The connection stores the settings needed to connect to the runtime system.

**To create a dial-up connection in Windows 95/98, complete the following steps:**

1. Double-click the *My Computer* icon on the desktop and then double-click the *Dial-Up Networking* folder.

   The Dial-Up Networking window appears.

2. Double-click the *Make New Connection* icon.
The Make a New Connection Wizard appears.

3. Enter the name of the computer you are dialing.
   **Important** The name must be “MachineShop Phonebook Entry” if you are using the Direct Connection (Serial) option in MachineShop.

4. Select **MachineShop Direct Connection** as the modem.

5. Click **Next**.

The following window appears.

6. Enter “1” as the telephone number and then click **Next**.
Appendix A: MachineShop Dial-Up Networking Connections

The following window appears.

![Make New Connection Window]

7. Click **Finish** to save the phonebook entry.

**Configure the Connection**

Now you need to configure the newly created connection.

To configure the connection, complete the following steps:


   The Dial-Up Networking window appears.

![Dial-Up Networking Window]

2. Right click on the icon for the newly created connection and then select **Properties**.
The property sheet for the selected connection appears.

3. Clear the **Use area code and Dialing Properties** check box on the General tab
4. Click **Configure** to set the baud rate for the MachineShop Direct Connection. The MachineShop Direct Connection property window appears.
5. Select the speed that modem will use to transfer data from the maximum speed list. The default is 115200. This selection must match the baud rate set in the MachineShop Shell.

*Note*  If you are have reliability problems using the selected speed, try selecting a slower speed.

6. Click **OK** to accept these choices.

The property sheet for the selected connection appears.

7. Click the **Server Types** tab.

The Server Types tab appears.

8. Clear all check boxes except the **TCP/IP** check box and then click **TCP/IP Settings** to configure the IP address.
Appendix A: MachineShop Dial-Up Networking Connections

The TCP/IP Settings window appears.

9. Select **Specify an IP address** and then enter the IP address for the development system.
   CTC recommends that you enter 10.0.0.1 as the IP address for the development system.
   
   **Note** If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

10. Select **Specify name server addresses**.
    Make sure all the addresses are set to 0.0.0.0.

11. Clear the **Use IP header compression** and **Use default gateway on remote network** check boxes.

12. Click **OK** to accept these choices.
    The property sheet for the selected connection appears.

13. Click **OK** to exit the property sheet.
Appendix A: MachineShop Dial-Up Networking Connections

Windows NT Dial-Up Networking
This section describes the steps to create and configure a dial-up connection in Windows NT.

Create a Dial-Up Connection
The phonebook entry will store the settings needed to connect to the runtime system. The phonebook entry is created using Windows Dial-Up Networking.

To create a phonebook entry in Windows NT, complete the following steps:

1. Double-click the My Computer icon on the desktop and then double-click the Dial-Up Networking folder.
   If there are no previous phonebook entries, the message “The phonebook is empty” appears.
   Note: If a phonebook entry already exists, the Dial-Up Networking window appears. Click New to add a new entry and skip to step 3.

2. Click Yes to add an entry.
   The New Phonebook Entry Wizard appears.

3. Enter a name for the new phonebook entry and then click Next.
   Important: The name must be “MachineShop Phonebook Entry” if you are using the Direct Connection (Serial) option in MachineShop.
The Server window appears.

4. Select **Send my plain text password if that’s the only way to connect** and then click **Next**.

The Phone Number window appears.

5. Enter **1** as the phone number and then click **Next**.

The New Phonebook Entry Wizard appears.

6. Click **Finish** to save the phonebook entry.

The Dial-Up Networking window appears with the new phonebook entry displayed in the Phonebook entry to dial box.
Appendix A: MachineShop Dial-Up Networking Connections

Configure the Connection
Now you need to configure the phonebook entry.

To configure the phonebook entry, complete the following steps:
   The Dial-Up Networking window appears.

2. Select the phonebook entry from the Phonebook entry list.
3. Click More and then select Edit entry and modem properties.
   The Edit Phonebook Entry property sheet appears.
Appendix A: MachineShop Dial-Up Networking Connections

4. **Click Configure** on the Basic tab to set the baud rate for the MachineShop Direct Connection.

   The Modem Configuration dialog box appears.

   ![Modem Configuration Dialog Box]

5. Select the speed that modem will use to transfer data from the initial speed list.

   The default is 115200. This selection must match the baud rate set in the MachineShop Shell.

   **Note** If you have reliability problems using the selected speed, try selecting a slower speed.

6. **Click OK.**

   The Edit Phonebook Entry property sheet appears

7. **Click the Server tab.**

   The Server tab appear.

   ![Edit Phonebook Entry Dialog Box]
8. Clear all check boxes except the **TCP/IP** check box and then click **TCP/IP settings** to configure the IP address.

The TCP/IP Settings window appears.

![TCP/IP Settings Window](image)

9. Select **Specify an IP address** and then enter the IP address for the development system.

   CTC recommends that you enter 10.0.0.1 as the IP address for the development system.

   **Note**  If you are using both serial and Ethernet point to point connections on the same development machine, you must have different IP addresses for each connection.

10. Select **Specify name server addresses**.

    Make sure all the addresses are set to 0.0.0.0.

11. Clear the **Use IP header compression** and **Use default gateway on remote network** check boxes.

12. Click **OK** to accept these choices.

    The Edit Phonebook Entry property sheet appears.

13. Click **OK** to exit the Edit Phonebook Entry property sheet.
Cable Pinouts

This appendix describes the cable pinouts for a LAN cable, crossover cable, serial cable with hand-shaking, and a serial null modem cable with loopback. If you should decide to construct your own cable, refer the appropriate diagram below for assistance.

10BaseT, 100BaseT LAN Cable Pinout

- Orange-white 1 ————1 Green-white
- Orange 2 ————2 Green
- Green-white 3 ————3 Orange-white
- Blue 4 ————4 Blue
- Blue-white 5 ————5 Blue-white
- Green 6 ————6 Orange
- Brown-white 7 ————7 Brown-white
- Brown 8 ————8 Brown

![RJ-45 Connector]
10BaseT, 100BaseT Peer to Peer Crossover Cable Pinout

Orange-white 1
Orange 2
Green-white 3
Blue 4
Blue-white 5
Green 6
Brown-white 7
Brown 8

1 Green-white
2 Green
3 Orange-white
4 Blue
5 Blue-white
6 Orange
7 Brown-white
8 Brown
## Serial Cable with Hardware Handshaking Pinout

<table>
<thead>
<tr>
<th>9-pin</th>
<th>25-pin</th>
<th>25-pin</th>
<th>9-pin</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pin 5</td>
<td>pin 7</td>
<td>&lt;--------&gt;</td>
<td>pin 7</td>
<td>pin 5</td>
</tr>
<tr>
<td>pin 3</td>
<td>pin 2</td>
<td>&lt;--------&gt;</td>
<td>pin 3</td>
<td>pin 2</td>
</tr>
<tr>
<td>pin 7</td>
<td>pin 4</td>
<td>&lt;--------&gt;</td>
<td>pin 5</td>
<td>pin 8</td>
</tr>
<tr>
<td>pin 6, 1</td>
<td>pin 6, 8</td>
<td>&lt;--------&gt;</td>
<td>pin 20</td>
<td>pin 4</td>
</tr>
<tr>
<td>pin 2</td>
<td>pin 3</td>
<td>&lt;--------&gt;</td>
<td>pin 2</td>
<td>pin 3</td>
</tr>
<tr>
<td>pin 8</td>
<td>pin 5</td>
<td>&lt;--------&gt;</td>
<td>pin 4</td>
<td>pin 7</td>
</tr>
<tr>
<td>pin 4</td>
<td>pin 20</td>
<td>&lt;--------&gt;</td>
<td>pin 6, 8</td>
<td>pin 1, 6</td>
</tr>
</tbody>
</table>

9-pin connector

```
5 (0 0 0 0 0 1)
9 (0 0 0 0 0 6)
```

25-pin connector

```
13 (0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1)
25 (0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 14)
```
Appendix B: Cable Pinouts

Serial Null Modem Cable with Loopback Pinout

<table>
<thead>
<tr>
<th>9-pin</th>
<th>25-pin</th>
<th>25-pin</th>
<th>9-pin</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pin 5</td>
<td>pin 7</td>
<td>pin 7</td>
<td>pin 5</td>
<td>Ground&lt;----&gt;Ground</td>
</tr>
<tr>
<td>pin 3</td>
<td>pin 2</td>
<td>pin 3</td>
<td>pin 2</td>
<td>Xmit&lt;----&gt;Rcv</td>
</tr>
<tr>
<td>pin 7</td>
<td>pin 4</td>
<td>pin 5</td>
<td>pin 8</td>
<td>RTS&lt;----&gt;CTS</td>
</tr>
<tr>
<td>pin 6, 1</td>
<td>pin 6, 8</td>
<td>pin 20</td>
<td>pin 4</td>
<td>DSR, CD&lt;----&gt;DTR</td>
</tr>
<tr>
<td>pin 2</td>
<td>pin 3</td>
<td>pin 2</td>
<td>pin 3</td>
<td>Xmit&lt;----&gt;Rcv</td>
</tr>
<tr>
<td>pin 8</td>
<td>pin 5</td>
<td>pin 4</td>
<td>pin 7</td>
<td>CTS&lt;----&gt;RTS</td>
</tr>
<tr>
<td>pin 4</td>
<td>pin 20</td>
<td>pin 6, 8</td>
<td>pin 1, 6</td>
<td>DTR&lt;----&gt;DSR, CD</td>
</tr>
</tbody>
</table>

**9-pin connector**

```
5 1
9 6
```

**25-pin connector**

```
13 1
25 14
```
A
add
  connection
disk transfer 60
  Ethernet point to point 43
  IPM compatible 58
LAN 40
  modem 55
  serial 52
  suite component 86
Always on Top 84
AutoHide 84

B
backup 64
  local 64
  remote 66
  restore 67
baud rate 92, 98
  modify 91, 97

C
cable pinouts 101
configure
dial-up connection
  Windows 95/98 91
  Windows NT 97
TCP/IP properties
  Windows 95/98 43
  Windows NT 46
connection
disk transfer 60
  Ethernet point to point 43
  IPM compatible 58
LAN 40
  modem 55
  serial 52
create
backup

disk transfer connection 60

E
edit I/O interface 37

Index

local project backup 64
remote project backup 66
dial-up connection
  Windows 95/98 89
  Windows NT 95
project 28
Crossover Cable Pinout 102
Customer Support Services 7
customizing MachineShop 83
  add suite component 86
  edit suite component 87
  remove suite component 88
  visibility 84
D
delete a project 34
development system requirements 11
Dial-Up Networking 55, 56, 89
  add connection
    Windows 95/98 89
    Windows NT 95
  configure connection
    Windows 95/98 91
    Windows NT 97
  modify
    baud rate 91, 97
    TCP/IP settings 91, 97
disk transfer connection 60
docking the toolbar 85
documentation 3
electronic 4
print 3
standards 6
download project 74
download command 76
transfer wizard 74
Index

Edit menu 20
edit project description 36
edit suite component 87
Ethernet point to point connection 43

F
File menu 20

H
hardware requirements
  development system 11
  runtime system 12
Help menu 21
Host Name 42

I
IP Address 42, 45, 48, 50, 57
IPM 17
IPM Compatible Serial connection 58

L
LAN Cable Pinout 101
LAN connection 40
  launch
    Interact 22, 33
    MachineLogic 22, 33

M
MachineLogic source file 76, 77
MachineLogic templates 28
MachineShop
  add suite component 86
  edit suite component 87
  features 10
  remove suite component 88
  start 18
  visibility 84
MachineShop Direct Connection modem 90
MachineShop Net 21, 40
MachineShop Net connection
  Ethernet point to point 43
  LAN 40
  modem 55
  serial 52
MachineShop Net Name 42
MachineShop Phonebook Entry 52, 53, 90
  create 89
Menus 20
  Edit menu 20
  File menu 20
  Help menu 21
  Tools menu 21
  Transfer menu 21
  View menu 20
  Window menu 21
  modem connection 55

O
Online Help 18
  open a project 32
  Options command 84

P
Product Support Program 8
Professional Consulting Services 8
project
  backup 64
  create 28
  delete 34
  description 36
  directory structure 26
  download 74
  I/O interface 37
  information 35
  open 32
  overview 26
Index

project path 27
restore 67
save 33
upload 78
Project Management Rebar 22

R
rebars 22
move 85
project management 22
suite navigation 22
transfer 23
remove suite component 88
restore 67
    local project 67
    remote project 70
runtime system requirements 12

S
save a project 33
security key 13
Security Key Utility 14
    enable software options 15
    transfer options between keys 16
Serial Cable with Hardware Handshaking
    Pinout 103
serial connection 52
Serial Null Modem Cable with Loopback
    Pinout 104
setting project path 27
software requirements
    development system 11
    runtime system 13
starting MachineShop 18
startup files 27, 35
Suite Navigation Rebar 22

T
    TCP/IP properties
    configure in Windows 95/98 43
    configure in Windows NT 46
    TCP/IP settings 93, 99
    modify 91, 97
    Technical Support 7
    Technical Support Department 7
Toolbar
    always on top 84
    dock 85
    hide 84
    move 85
    moving 20
    undock 85
    visibility 84
Toolbars 22
Tools menu 21
Training and New Business Development 8
    Transfer menu 21
    Transfer Rebar 23

U
undocking the toolbar 85
upload project 78
    transfer wizard 78
    upload command 80
user interface 20
user-defined toolbar buttons
    add 86
    remove 88

V
    View menu 20
    view project information 35

W
    Welcome dialog 19
    What’s This Help 18
    Window menu 21